part01

GRAN-3D

1. Начало работы с программой. Обращение к услугам программы

1.1. Активизация программы

Программа GRAN-3D предназначена для графического анализа пространственных (трехмерных) объектов, откуда и происходит ее название (GRaphic Analysis 3-Dimension).

Программа функционирует под управлением операционной системы Windows9x. После успешной установки в указанном директории будет создан файл GRAN3D.EXE - основная программа, а также будут созданы вспомогательные файлы помощи. Далее при "нажатии" кнопки Пуск название программы GRAN-3D будет появляться как пункт меню Программы, при обращении к которому будет происходить запуск ППС GRAN-3D.

1.2. Обозначения, которые используются в тексте

В тексте курсивом выделяются надписи и названия услуг, относящиеся к интерфейсу программы. В дальнейшем указать некоторый объект будет означать подвести указатель мыши к соответствующему названию или изображению и нажать левую клавишу мыши. "Обратиться к услуге", "Активизировать услугу" будет означать установить указатель на название нужной услуги соответствующего меню программы (с помощью использования клавиш управления курсором или указателя мыши) и нажать клавишу Enter или левую клавишу мыши. Запись вида "обратиться к услуге Вычисление\Угол\По трем точкам" будет означать "обратиться к пункту главного меню Вычисление, далее к подпункту Угол, и затем к подпункту По трем точкам ".

1.3. Основные элементы интерфейса. Обращение к услугам программы

После активизации ППС GRAN-3D на экране появится главное окно программы. Сверху под заглавием главного окна расположено главное меню - перечень услуг, к которым можно обратиться в процессе работы с программой. При обращении к определенному пункту главного меню появляется перечень пунктов (услуг) соответствующего подменю. Пункты подменю в свою очередь могут разветвляться на подпункты, перечень которых появляется при обращении к соответствующему пункту подменю.

Во время работы с программой в некоторых ситуациях использование определенных услуг меню не является корректным. Такие пункты меню будут выделяться бледным цветом, а обращение к ним не приведет к каким либо действиям. Например, использование услуг пункта главного меню Объект - Изменить или Удалить в начале работы с программой, пока еще не создан ни один объект, не является корректным, поскольку еще нечего изменять или удалять.

Если необходимо отказаться от работы с только что выбранной услугой, следует обратиться к услуге Объект\Прекратить выполнение операции, или нажать клавишу ESC.

Обращение к отдельным услугам программы (без перебирания пунктов главного меню и подпунктов соответствующих подменю) при необходимости можно осуществить с помощью функциональных клавиш или комбинаций клавиш, указанных справа возле названий пунктов главного меню.

1.3.1. Панель инструментов

Для активизации некоторых услуг можно воспользоваться кнопками быстрого вызова операций на панели инструментов, которая расположена под главным меню программы. Для этого надо нажать соответствующую кнопку (то есть установить указатель мыши на обозначение кнопки и нажать левую клавишу мыши). "Кнопки" оснащены системой оперативной подсказки, поэтому во время нахождения указателя мыши над определенной "кнопкой" на экране появляются краткие сведения о ее назначении.

1.3.2. Поле Подсказки

Под панелью инструментов размещено поле Подсказки, в котором выводятся краткие сообщения о том, какое действие необходимо выполнить на текущем этапе работы.

1.3.3. Поле Изображения

Поле Изображения - часть главного окна программы, в которой изображаются созданные объекты и оси координат. Справа и внизу этого поля размещены полосы поворота изображения, с помощью которых осуществляется поворот изображений объектов. При смене положения указателя вертикальной полосы поворота будет происходить поворот изображения вокруг горизонтали, которая проходит через центр поворота (центр поворота может находиться в любой точке пространства, а его координаты можно установить на вкладыше Общие окна Настройки, см.§16), а при смене положения указателя горизонтальной полосы поворота будет происходить поворот изображения вокруг оси 0z. Чтобы изменить положение указателя полосы поворота, следует подвести к нему указатель мыши, после чего, нажав и удерживая левую клавишу мыши, переместить указатель в нужное положение и отпустить левую клавишу мыши.

1.3.4. Перечень объектов

Перечень объектов - поле, содержащее перечень названий всех объектов, которые были созданы или загружены в процессе работы с программой (в начале работы с программой указанное поле не содержит ни одного названия). Объект, на названии которого находится указатель, считается текущим. Изменение положения указателя текущего объекта осуществляется с помощью указателя мыши (нужно указать на название объекта, который необходимо сделать текущим) или с помощью клавиш управления курсором.

В поле Изображения выводятся изображения лишь тех объектов, перед названиями которых в перечне объектов стоит отметка. Чтобы временно удалить или вывести изображение объекта в поле Изображения, необходимо подвести к квадратику слева от названия соответствующего объекта указатель мыши и нажать ее левую клавишу. Двойной щелчок левой клавишей мыши приведет к активизации услуги Объект\Изменить для данного объекта.

1.3.5. Поле Характеристики объекта

Поле Характеристики объекта - часть главного окна, где выводятся некоторые параметры текущего объекта: его название, наибольшие и наименьшие значения координат вершин многогранника, количество вершин и т.п.

1.3.6. Поле Отчет

Поле Отчет - часть главного окна, где фиксируется протокол работы программы и куда выводятся результаты всех измерений и вычислений. Для очищения поля отчета нужно обратиться к услуге главного меню Настройки\Очистить отчет, или, установив указатель мыши над этим полем, нажать правую клавишу мыши и в появившемся выпадающем меню выбрать соответствующую услугу.

1.3.7. Поле информирования

Поле информирования - поле (внизу экрана), где выводятся пространственные координаты точки, которая соответствует текущему положению указателя мыши в поле Изображения (если координаты такой точки можно определить однозначно), название объекта, которому эта точка принадлежит, длина отрезка (если указатель находится на изображении отрезка) и т.п. В поле информирования выводится также краткая информация об элементах интерфейса ППС GRAN-3D, над которыми находится указатель мыши.


part02

2. Система координат. Картинная плоскость проекции

2.1. Изображение координатных осей. Масштаб изображения

Сразу после загрузки программы GRAN-3D в поле Изображения появляется изображение осей координат, на которых указаны значения делений, определяющих длины единичных отрезков вдоль этих осей. Соотношение масштабов изображения вдоль любой из осей можно изменить с помощью услуги Настройки\Параметры на вкладыше Изображение окна Настройки (см.§16). Для увеличения или уменьшения масштаба изображения предназначены услуги Изображение\Увеличить и Изображение\Уменьшить. После обращения к услуге Изображения\Подобрать размер будет установлен предусмотренный в программе масштаб изображения.

2.2. Поворот системы координат

С помощью полос поворота изображения можно вращать систему координат вместе с созданными моделями объектов. Центром поворота может быть точка с произвольными пространственными координатами (по умолчанию центром поворота есть точка с координатами (0,0,0)). Чтобы изменить координаты центра поворота, следует воспользоваться услугой Настройки\Параметры на вкладыше Изображение окна Настройки (см.§16).Для поворота системы вокруг оси Oz предназначена горизонтальная полоса поворота изображения, а для поворота вокруг горизонтали, которая проходит через центр поворота, предназначена вертикальная полоса поворота изображения. Для поворота системы можно использовать также клавиши управления курсором.

2.3. Вырождение пространства в плоскость. Изометрия

Для быстрой установки системы в положение изометрии или в положение, при котором изображение одной из координатных осей вырождается в точку, предназначены услуги пункта меню Изображение\Положение координатных осей - Вирождена ось Ox, Вирождена ось Oy, Вирождена ось Oz и Изометрия.

2.4. Определение координат точек

Если подвести указатель мышки к любой линии произвольного объекта, указанная линия выделяется пунктиром и в поле информирования автоматически выводятся пространственные координаты точки, которая соответствует текущему положению указателя, и название объекта, которому эта точка принадлежит. В случае, если система размещена так, что одна из координатных осей вырождается в точку (то есть координатная плоскость, которая определяется другими двумя осями, размещена параллельно плоскости изображения), автоматически вычисляются (и выводятся в поле информирования) координаты точки, которая соответствует текущему положению указателя мыши в плоскости изображения. Координата вдоль вырожденной оси считается неизвестной.

2.5. Полутоновое изображение объектов

Для повышения наглядности моделей стереометрических тел можно воспользоваться услугой программы Изображение\Режим полутонового изображения, использование которой позволяет получать "реалистическое" изображение моделей этих тел, построенное с учетом видимости линий и плоскостей.


part03

3. Ввод выражений

В ППС GRAN-3D числовые значения и выражения записываются по правилам, близким к правилам, принятым в наиболее распространенных языках программирования высокого уровня (Basic, Pascal и т.п.), и соответствующим правилам ППС GRAN1, GRAN-2D.

В числовых значениях дробная часть, если она есть, отделяется от целой части точкой (в тексте числа подаются по этим же правилам).

Арифметические операции обозначаются знаками:

+ сложение,

- вычитание,

* умножение,

/ деление,

^ возведение в степень.

Порядок выполнения операций - общепринятый. Чтобы указать желаемый порядок выполнения операций, можно воспользоваться скобками. Выражение, записанное в скобках, рассматривается как единое целое и вычисляется в первую очередь. Выражения в скобках в свою очередь могут содержать выражения в скобках и т.д. Каждой открывающей (левой) скобке должна соответствовать закрывающая (правая) скобка.

3.1. Обозначение некоторых функций

В выражения могут быть включены обозначения (которые рассматриваются как неделимые символы) некоторых функций. Перечень обозначений допустимых функций представлен на панели калькулятора:

Sin - sin (синус),

Cos - cos (косинус),

Tg - tg (тангенс),

Сtg - ctg (котангенс),

Asin - arcsin (арксинус),

Acos - arccos (арккосинус),

Atg - arctg (арктангенс),

Actg - arcctg (арккотангенс),

Exp - ex (экспонента),

Ln - logex логарифм натуральный (по основанию e),

Lg - log10x логарифм десятичный (по основанию 10),

Sqrt - корень квадратный,

Int - целая часть аргумента,

Abs - абсолютное значение (модуль),

Pi - 3.141592654.

3.2. Ввод выражений с помощью мыши. Панель калькулятора

Использование панели калькулятора с цифровыми кнопками и кнопками быстрого ввода названий стандартных функций позволяет вводить выражения с помощью мыши, без использования клавиатуры. Для ввода необходимого символа следует "нажать" (с помощью мыши) кнопку с пиктограммой этого символа на панели калькулятора. Без использования панели калькулятора все необходимые символы можно ввести с клавиатуры.


part04

4. Создание моделей пространственных объектов

4.1. Общие сведения

Используя ППС GRAN-3D, можно создавать и оперировать моделями геометрических объектов представленных ниже типов: точка, отрезок, ломаная, плоскость, многогранник, поверхность вращения и произвольная поверхность, которая определяется уравнением вида z=f(x,y). При этом возможно создание объектов разными способами.

Точка задается своими пространственными координатами x, y и z, отрезок - двумя точками или точкой и направляющим вектором, ломаная - координатами узлов или точкой и упорядоченным набором векторов (ломаная может быть замкнутой или незамкнутой), плоскость - тремя точками, точкой и вектором нормали или коэффициентами A, B, C, D уравнения плоскости вида Ax+By+Cz+D=0.

Многогранник задается совокупностью граней, где каждая грань - треугольник, который определяется некоторыми тремя вершинами многогранника, а каждая вершина задается своими пространственными координатами.

Поверхность - пространственный объект, который описывается совокупностью уравнений вида z=f(x,y), для каждого из которых указывается область задания в виде системы неравенств вида g(x,y)£0 или как многоугольник в плоскости xOy.

Поверхность вращения - поверхность, которая образовывается вращением вокруг оси Ox или Oy некоторой плоской кривой или ломаной, которые лежат в плоскости xOy. При этом кривую можно задать аналитически явной зависимостью между переменными x и y в виде y=f(x) или же параметрической в виде x=f(t), y=g(t), а ломаную можно задать или введя координаты ее вершин, или указав вершины на экране с помощью мыши.

Для создания некоторого объекта следует обратиться к услуге Объект\Создать с названием, отвечающим желаемому типу объекта. В результате появится окно Конструирование объекта, в котором на вкладыше с названием типа создаваемого объекта следует указать параметры объекта. Для объектов всех типов можно указать цвет их изображения и название.

После ввода параметров создаваемого объекта следует "нажать" кнопку Выполнить. Заметим, что если введенные параметры объекта не являются корректными, кнопка Выполнить будет недоступна, а в поле сообщений будет выведено соответствующее сообщение об ошибке.

После создания объекта его изображение появится в поле Изображения, а его название появится в перечне объектов.

4.2. Создание объекта типа Точка

Для создания объекта типа Точка необходимо обратиться к услуге меню Объект\Создать\Точка. В появившемся окне Конструирование объекта на вкладыше Точка следует ввести пространственные координаты точки и "нажать" кнопку Выполнить.

4.3. Создание объекта типа Ломаная

Для создания ломаной (или отрезка) следует обратиться к услуге Объект\Создать\Ломаная. В появившемся окне Конструирование объекта на вкладыше Ломаная нужно ввести параметры ломаной. С помощью переключателя Способ задания следует указать способ задания ломаной - координатами вершин или координатой первой вершины и последовательностью направляющих векторов, которая будет определять все другие вершины.

Далее следует указать, какой должна быть ломаная: замкнутая или незамкнутая (для этого нужно с помощью мыши установить или снять отметку возле надписи Замкнутая).

В зависимости от положения переключателя Способ задания следует ввести в таблицу координаты вершин ломаной или координату первой вершины и последовательность координат векторов, которые определяют вершины ломаной.

Чтобы добавить или удалить текущую строку таблицы, следует воспользоваться кнопками с изображениями "+" или "-", размещенными справа от таблицы. Количество строк таблицы определяет количество вершин ломаной. Для подтверждения ввода данных нужно "нажать" кнопку Выполнить.

4.4. Создание объекта типа Плоскость

Для создания объекта типа Плоскость необходимо обратиться к услуге меню Объект\Создать\Плоскость. В результате появится окно Конструирование объекта, в котором на вкладыше Плоскость следует указать параметры плоскости.

Прежде всего необходимо указать способ задания плоскости: тремя точками, точкой и вектором нормали или коэффициентами A,B,C,D уравнения плоскости вида Ax+By+Cz+D=0 (воспользовавшись переключателем Способ задания). Если выбран способ задания Три точки, в соответствующие поля ввода нужно ввести пространственные координаты трех точек, которые будут определять плоскость. Если же выбран способ задания Точка и вектор нормали, в соответствующие поля необходимо ввести пространственные координаты точки и вектора нормали, которые будут определять плоскость. В случае, если выбран способ задания Уравнение Ax+By+Cz+D=0, в соответствующие поля необходимо ввести коэффициенты A,B,C,D, определяющие уравнение плоскости.

Для подтверждения ввода данных следует "нажать" кнопку Выполнить.

Плоскость будет изображаться в виде некоторого треугольника с пунктирными сторонами. Если плоскость была задана тремя точками, то эти три точки будут соответствовать вершинам треугольника на изображении. Во всех других случаях задания плоскости координаты вершин треугольника подбираются по программе автоматически так, чтобы треугольник лежал в указанной плоскости и в то же время был размещен как можно ближе к началу координат.

4.5. Создание объекта типа Многогранник

Для создания объекта типа Многогранник нужно обратиться к услуге меню Объект\Создать\Многогранник, что приведет к появлению окна Конструирование объекта с вкладышем Многогранник.

Средствами ППС GRAN-3D можно создать произвольный многогранник. Для этого необходимо в соответствующих полях указать количество вершин многогранника и количество треугольных граней (не треугольные грани нужно поделить на треугольники), ввести координаты вершин многогранника в таблицу Вершины, а также указать по три вершины на каждой грани.

Для выпуклых многогранников можно не указывать количество треугольных граней и номера вершин для каждой грани. Достаточно сначала ввести вершины многогранника, а потом воспользоваться услугой Сформировать грани выпуклого объекта - количество граней и соответствующие номера вершин для каждой грани будут установлены автоматически. Для подтверждения ввода данных следует "нажать" кнопку Выполнить.

4.6. Создание объекта типа Поверхность

Чтобы создать объект типа Поверхность, необходимо обратиться к услуге меню Объект\Создать\Поверхность, что приведет к появлению окна Конструирование объекта с вкладышем Поверхность.

Поверхность описывается совокупностью уравнений вида z=f(x,y), для каждого из которых указывается область задания в виде системы неравенств вида g(x,y)£0 или как многоугольник в плоскости xOy. Области задания "фрагментов" поверхности не должны пересекаться.

Под надписью Части поверхности и их области задания приведен перечень фрагментов, которые составляют поверхность (сначала в перечне есть лишь один фрагмент). Текущий фрагмент выделен темным прямоугольником. Чтобы добавить фрагмент, следует "нажать" кнопку "+" (справа от перечня), а чтобы удалить текущий фрагмент, следует "нажать" кнопку "-".

В поле возле надписи z(x,y)= необходимо ввести аналитическое выражение от аргументов x и y, которое описывает текущий фрагмент поверхности (например, sin(x+y)).

Под надписью Способ указания области задания размещены кнопки Система неравенств и Многоугольник. В зависимости от того, как удобнее указать область задания текущего фрагмента поверхности, нужно "нажать" кнопку с соответствующей надписью.

Если выбран способ указания области задания в виде системы неравенств, то в поле возле надписи Q= нужно ввести неравенство или систему неравенств (неравенства одно от другого отделяются запятыми), которые описывают область задания текущего фрагмента поверхности (например, x>0,y<5 или x^2+y^2<4^2 и т.п.). Если указанное поле оставить пустым, то область задания будет неограниченной.

Если установлен способ указания области задания в виде многоугольника, то нужно ввести координаты каждой вершины многоугольника, который ограничивает область задания текущего фрагмента поверхности, в таблицу. При этом для добавления новой строки к таблице следует "нажать" кнопку "+", а для удаления текущей строки - кнопку "-". Для очистки таблицы можно воспользоваться кнопкой с изображением чистого листа.

Вершины многоугольника также можно задать "графически" с экрана (указав их положения с помощью мыши). Для этого нужно "нажать" кнопку Графически и в появившемся окне Графическое задание многоугольника указать вершины соответствующего многоугольника.

В рамке Пределы табулирования (для изображения) в соответствующих полях следует указать пределы области табулирования поверхности, которые используются при построении ее изображения. Изображение созданной поверхности будет состоять лишь из тех фрагментов поверхности, которые определены как в области задания, так и в области табулирования.

4.7. Создание объекта типа Поверхность вращения

Для того, чтобы исследовать поверхность вращения с помощью ППС GRAN-3D, необходимо создать соответствующую ей модель - объект типа Поверхность вращения. Для этого следует обратиться к услуге главного меню программы Объект\Создать\Поверхность вращения. В появившемся окне Конструирование объекта с вкладышем Поверхность вращения нужно указать тип зависимости, которая описывает образующую (образующая - плоская кривая в плоскости xOy, вращением которой вокруг выбранной оси образуется поверхность), и параметры образующей.

Прежде всего, воспользовавшись переключателем Тип зависимости, необходимо выбрать тип задания образующей. Если выбран тип y=f(x), то в поле возле надписи y= следует ввести выражение от аргумента x, а в полях возле надписей от x= и до x= нужно указать пределы допустимых значений аргумента х.

Если выбран тип x=f(t), y=g(t), то в поля возле надписей x= и y= нужно ввести выражения от аргумента t, а в поля возле надписей от t= и до t= указать пределы допустимых значений аргумента t.

Если выбран тип Ломаная, то нужно задать ломаную-образующую в плоскости xOy, причем ломаную можно задать или введя координаты ее вершин в соответствующую таблицу, или графически. В последнем случае нужно "нажать" кнопку Графически>>> и в появившемся окне Графическое задание ломаной с помощью мыши указать вершины ломаной.

После задания образующей необходимо (с помощью переключателя Вращение вокруг оси) выбрать ось (Ox или Oy), вокруг которой будет осуществляться вращение образующей.

Для удобства во время ввода выражений автоматически осуществляется синтаксический контроль введенной записи, поэтому в случае некорректного ввода выражения сразу же выводится (в поле сообщений) соответствующее сообщение об ошибке, а введенная запись изображается красным цветом.

В правой части окна выводится изображение образующей в плоскости x0y.

По желанию можно указать вектор переноса, на который будет после создания перенесена поверхность вращения относительно центра координат. Для подтверждения ввода данных следует "нажать" кнопку Выполнить.

4.8. Графическое задание объектов типа Точка, Ломаная, Плоскость

Объекты типа Точка, Ломаная и Плоскость можно задавать "с экрана", указав точки, которые определяют эти объекты, непосредственно в поле Изображения с помощью мыши. Для создания объектов указанных типов описанным способом следует обратиться к услуге меню Oбьект\Создать с экрана\Точка, Oбьект\Создать с экрана\Ломаная или Oбьект\Создать с экрана\Плоскость, в зависимости от того, объект какого типа необходимо создать. На соответствующий запрос программы, который появится в поле подсказки, необходимо в поле Изображения указать (с помощью указателя мыши) точки, которые будут определять объект, после чего в появившемся (после указания последней точки) окне Конструирование объекта откорректировать некоторые параметры объекта (если это необходимо) и "нажать" кнопку Выполнить.

Для создания объекта типа Точка нужно указать лишь одну точку.

Для создания объекта типа Ломаная нужно указать столько точек, сколько вершин имеет ломаная. Указав последнюю вершину ломаной, нужно нажать правую клавишу мыши.

Для создания объекта типа Плоскость следует указать три точки, через которые должна проходить плоскость.

"Указать точку" означает подвести указатель мыши в поле Изображения к изображению любой вершины или линии (ребра) любого созданного объекта так, чтобы в поле информирования появились координаты точки и название объекта, которому она принадлежит, и нажать левую клавишу мыши. Если одна из координатных плоскостей размещена (с помощью полос поворота изображения) параллельно плоскости изображения, тогда можно подвести курсор мыши к любой точке плоскости так, чтобы в поле информирования появились координаты этой точки, и нажать левую клавишу мыши. Координата точки вдоль вырожденной оси будет считаться равной 0.

4.9. Изменение параметров объектов

Если возникла необходимость изменить параметры ранее созданного объекта, нужно установить указатель перечня объектов в положение, соответствующее названию нужного объекта, и обратиться к услуге Объект\Изменить. В результате появится окно Конструирование объекта с параметрами текущего объекта, которые можно изменять так же, как при создании этого объекта.

4.10. Удаление объектов

Для удаления некоторого объекта нужно установить указатель перечня объектов в положение, соответствующее названию этого объекта, и обратиться к услуге программы Объект\Удалить (или нажать клавишу Del). После этого появится запрос "Удалить объект?" с кнопками Да и Нет. Если "нажать" кнопку Да, текущий объект будет удален.


part05

5. Создание моделей базовых пространственных объектов

Модели базовых пространственных объектов, которыми оперируют в школе при изучении стереометрии (куб, правильная призма, прямой параллелепипед, цилиндр, шар, правильная обычная или срезанная пирамида, конус, усеченный конус) можно создавать, указав лишь необходимые параметры объекта в окне Создание базовых пространственных объектов на вкладыше с соответствующим названием, которое появляется при обращении к услуге программы Объект\Создать базовый объект.

5.1. Создание прямого параллелепипеда

Вкладыш Прямой параллелепипед содержит средства для создания прямых параллелепипедов. С помощью переключателя Основание следует установить тип задания основания параллелепипеда и ввести соответствующие значения в поля под указанным переключателем. Также следует указать высоту или объем тела (в зависимости от положения левого переключателя). Введя все необходимые данные, нужно "нажать" кнопку Создать.

5.2. Создание конуса

Для создания модели конуса на вкладыше Конус с помощью переключателя Нижнее основание следует указать способ задания нижнего основания и ввести значение соответствующей величины в поле под указанным переключателем (если необходимо создать усеченный конус, то следует установить отметку возле надписи Усеченный и аналогично предыдущему задать верхнее основание). Кроме того следует указать высоту или длину образующей конуса (в зависимости от положения левого переключателя). После ввода данных следует "нажать" кнопку Создать.

5.3. Создание цилиндра

Для создания модели цилиндра на вкладыше Цилиндр следует указать способ задания основания (с помощью переключателя Основание) и ввести значение соответствующей величины в поле под переключателем. Кроме того следует указать высоту или объем цилиндра (в зависимости от положения левого переключателя). После ввода данных следует "нажать" кнопку Создать.

5.4. Создание шара

Для создания модели шара на вкладыше Шар следует указать способ задания шара (с помощью переключателя Способ задания шара) и ввести значение соответствующей величины в поле под переключателем, а также координаты центра шара. После ввода данных следует "нажать" кнопку Создать.

5.5. Создание куба

На вкладыше Куб размещены средства для упрощенного создания модели куба. Указав способ задания куба (с помощью переключателя Способ задания куба) и введя соответствующее значение в поле под переключателем, нужно "нажать" кнопку Создать.

5.6. Создание правильной пирамиды

Для создания модели правильной пирамиды на вкладыше Правильная пирамида следует указать способ задания нижнего основания (с помощью переключателя Нижнее основания) и ввести соответствующее значение в поле под указанным переключателем (если необходимо создать усеченную пирамиду, то следует установить отметку возле надписи Усеченная и аналогично предыдущему задать параметры верхнего основания). Кроме того, нужно указать количество вершин в основании пирамиды и высоту или длину бокового ребра пирамиды (в зависимости от положения левого переключателя). После ввода данных нужно "нажать" кнопку Создать.

5.7. Создание правильной призмы

Вкладыш Правильная призма предназначен для создания модели прямой правильной призмы. Для создания призмы необходимо указать способ задания основания (с помощью переключателя Задание основания) и ввести значение соответствующей величины в поле под переключателем, указать высоту или объем призмы (в зависимости от положения левого переключателя), а также указать количество вершин в основании призмы. После ввода данных нужно нажать кнопку Создать.

Независимо от того, какой базовый объект создается, после нажатия кнопки Создать появляется окно Конструирование объекта с вкладышем, соответствующим типу создаваемого объекта, на котором уже заполнены все необходимые поля данных для создания объекта (см.§4). При желании можно изменить цвет, название или другие параметры создаваемого объекта. После "нажатия" кнопки Выполнить соответствующий объект будет создан.


part06

6. Сохранение, загрузка и удаление созданных объектов

6.1. Сохранение созданных объектов

Для сохранения созданных объектов в файле следует обратиться к услуге главного меню Файл\Сохранить. Если объекты сохраняются впервые, то на запрос программы в стандартном окне сохранения файлов системы Windows необходимо указать имя файла и целевой директорий.

При необходимости сохранить объекты, которые уже ранее сохранялись, в файле с другим именем, следует воспользоваться услугой главного меню Файл\Сохранить как, что приведет к появлению стандартного запроса Windows, в ответ на который необходимо указать новое имя файла и целевой директорий.

6.2. Загрузка созданных объектов

Для загрузки ранее сохраненных объектов предназначена услуга Файл\Загрузить. На стандартный запрос системы Windows, появляющийся при обращении к указанной услуге, необходимо указать имя файла, в котором были сохранены объекты.

Если нужно загрузить не все объекты из файла, а лишь некоторые из них, можно воспользоваться услугой Файл\Загрузить выборочно. После указания имени файла (на запрос программы) появляется окно с перечнем всех объектов, которые помещаются в данном файле.

Необходимо поставить отметки (с помощью мыши) возле названий тех объектов в перечне, которые нужно загрузить. Если поставить отметку возле надписи прибавить к уже созданным, указанные объекты будут добавлены к объектам, созданным во время текущего сеанса работы с программой. В противном случае все ранее созданные объекты будут удалены. Отметка возле надписи параметры из файла указывает на то, необходимо ли загружать информацию о положении координатных осей и масштаб изображения из выбранного файла. После "нажатия" кнопки Загрузить отмеченные объекты будут загружены.

Имя рабочего файла (то есть файла, в котором сохранены или из которого загружены объекты) будет выводиться в заголовке главного окна программы (если в параметрах настроек программы установлена опция Выводить путь к рабочему файлу в главном окне).

6.3. Удаление созданных объектов

Обращение к услуге главного меню Файл\Новый приведет к удалению всех ранее созданных объектов и очищению поля отчета, то есть будет выполнена подготовка к новому сеансу работы.

6.4. Завершение работы с программой

Для завершения работы с программой необходимо обратиться к пункту меню Файл\Выход. Если во время работы с программой были созданы объекты, которые не были сохранены в файле, то появится сообщение, в котором будет предложено сохранить объекты.


part07

7. Xарактеристики объектов

7.1. Характеристики текущего объекта

Некоторые характеристики объектов вычисляются автоматически сразу после создания объектов или после их преобразования. Для объектов всех типов вычисляются (и выводятся в поле Характеристики) минимальные и максимальные координаты точек вдоль каждой из координатных осей. Кроме этого, для объектов каждого отдельного типа выводится некоторая дополнительная информация:

  • для объектов типа Ломаная вычисляется длина ломаной, а если ломаная замкнута и все ее вершины лежат в одной плоскости, то также вычисляется площадь области, ограниченной ломаной;

  • для объектов типа Плоскость, независимо от способа задания, вычисляются коэффициенты A, B, C и D уравнения плоскости вида Ax+By+Cz+D=0;

  • для объектов типа Многогранник вычисляется объем и площадь поверхности, а также площадь и периметр отдельно каждой грани (эти характеристики приводятся в окне Перечень граней объекта, которое появится при обращения к услуге Вычисление\Многогранник\Площади и периметры граней);

  • для объектов типа Поверхность возможно вычисление объемов и площадей поверхностей тел, которые ими ограничиваются (эти сведения доступны через услугу главного меню Вычисление\Двойной интеграл и площадь поверхности);

  • для объектов типа Поверхность вращения вычисляются площадь поверхности, образованной вращением графика некоторой функции или ломаной, и объем тела, ограниченного такой поверхностью.


part08

8. Преобразования объектов

В ППС GRAN-3D предусмотрено осуществление параллельного переноса, поворота и деформации объектов. Для этого предназначены услуги пункта главного меню Операции.

Услугой Операции\Преобразования объектов можно воспользоваться при необходимости выполнить параллельный перенос, поворот или изменение размеров текущего объекта. В окне Операции над объектом с вкладышами Параллельный перенос, Поворот и Деформация, появляющемся после активизации указанного пункта меню, следует перейти на вкладыш с названием требуемой операции и, указав параметры операции, "нажать" кнопку Выполнить.

8.1. Преобразование Параллельный перенос

Для выполнения параллельного перенос текущего объекта на некоторый вектор (a,b,c) следует перейти на вкладыш Параллельный перенос. В поля возле надписей a=, b=, c= необходимо ввести координаты вектора и "нажать" кнопку Выполнить. В случае повторного "нажатия" указанной кнопки будет еще раз выполнен параллельный перенос текущего объекта на заданный вектор. Данная услуга не применяется к объектам типа Поверхность.

8.2. Преобразование Поворот

Если необходимо выполнить поворот текущего объекта на некоторый угол вокруг оси Ox, Oy или Oz, нужно перейти на вкладыш Поворот. С помощью переключателя Вокруг оси необходимо указать ось, вокруг которой нужно осуществить поворот, а также ввести величину угла поворота (в градусах) в поле возле соответствующей надписи. После "нажатия" кнопки Выполнить операция поворота будет применена к текущему объекту. Услуга не применяется к объектам типа Поверхность и Поверхность вращения.

8.3. Преобразование Деформация

В случае необходимости увеличить или уменьшить размеры объекта вдоль направлений осей Ox, Oy, Oz, следует перейти (с помощью мыши) на вкладыш Деформация. В поля возле соответствующих надписей необходимо ввести коэффициенты деформации вдоль каждого из направлений Ox, Oy, Oz.

После "нажатия" кнопки Выполнить x-, y- и z-координаты всех точек текущего объекта будут умножены на соответствующие коэффициенты. Если значение коэффициента находится в пределах от 0 до 1, то размеры объекта будут уменьшаться вдоль соответствующего направления, если же больше единицы - то увеличиваться. Если коэффициент отрицательный, тогда кроме изменения размеров происходит также отображение объекта относительно соответствующей координатной плоскости.

По умолчанию значения коэффициентов деформации вдоль каждой из осей устанавливаются равными 1.

Услуга не применяется к объектам типа Поверхность и Поверхность вращения.

8.4. Преобразование объектов "Вручную"

В случае, если оси координат в поле изображения установлены (с помощью полос поворота изображения) в такое положение, при котором изображение одной из осей вырождается в точку, то есть одна из координатных плоскостей становится параллельной плоскости изображения, можно осуществлять операции над объектами "вручную". Для этого предназначены услуги пункта меню Операции - Параллельный перенос, Поворот, Изменение размеров и Изменение формы.

8.4.1. Параллельный перенос

Параллельный перенос - услуга используется, если необходимо выполнить перенос некоторого объекта параллельно плоскости изображения (то есть плоскости x0y, x0z или y0z, в зависимости от того, какая из осей вырождена). Установив указатель мыши над изображением необходимого объекта так, чтобы в поле информирования появилось название этого объекта, следует нажать левую клавишу мыши и удерживая ее нажатой, переместить указатель мыши в нужное положение. При этом объект переместится вместе с указателем мыши. После освобождения левой клавиши мыши объект будет зафиксирован в новом положении в пространстве. Услуга не применяется к объектам типа Поверхность.

8.4.2. Поворот

Поворот - услуга используется, если необходимо выполнить поворот некоторого объекта вокруг направления вырожденной оси. Установив указатель мыши на изображение нужного объекта и нажав левую клавишу мыши (удерживая ее нажатой), следует перемещать указатель мыши в направления поворота - объект будет вращаться (относительно некоторой точки внутри объекта) в одну или другую сторону на угол, который определяется положением указателя мыши относительно некоторой точки внутри объекта. После освобождения левой клавиши мыши объект будет зафиксирован в новом положении.

Услуга не применяется к объектам типа Точка, Поверхность и Поверхность вращения.

8.4.3. Изменение размеров

Изменение размеров - услуга используется, если необходимо выполнить деформирование (увеличение или уменьшение размеров вдоль одного из направлений невырожденных осей) некоторого объекта. Установив указатель мыши на изображение необходимого объекта (так, чтобы в поле информирования появилось название объекта), нажав затем левую клавишу мыши и удерживая ее нажатой, следует переместить указатель мыши - объект будет увеличиваться или уменьшаться вдоль одной или обоих координатных осей соответственно текущему положению указателя мыши относительно некоторой точки внутри объекта. После изменения размеров объекта нужно освободить левую клавишу мыши.

Услуга не применяется к объектам типа Точка, Поверхность и Поверхность вращения.

8.4.4. Изменение формы

Изменение формы - услуга используется, если необходимо выполнить перенос параллельно плоскости x0y, x0z или y0z (плоскости, параллельной плоскости изображения) одной из вершин некоторого объекта типа Точка, Плоскость, Ломаная или Многогранник.

Установив указатель мыши на изображение нужной вершины объекта (так чтобы в строке информирования появилось название этого объекта и вершина, которую необходимо переместить, "подсветилась"), нажав затем левую клавишу мыши и удерживая ее нажатой, следует переместить указатель мыши в нужное положение (зафиксированная вершина будет перемещаться вместе с указателем мыши). После освобождения левой клавиши мыши выбранная вершина объекта будет зафиксирована в новом положении в пространстве. Услуга не применяется к объектам типа Поверхность и Поверхность вращения.

Иногда в результате выполнения описанной операции относительно объекта типа Многогранник может возникнуть ситуация, когда данный объект перестает быть корректно заданным (например, после переноса одной из вершин произошло "перекрещение" нескольких граней). В этом случае появится соответствующее сообщение и предложение откорректировать объект в окне Конструирование объекта.


part09

9. Вычисление объемов и площадей поверхностей многогранников

Объемы и площади поверхностей объектов типа Многогранник (пирамида, призма, параллелепипед, куб и т.п.) вычисляются автоматически при создании или преобразовании этих объектов. Вычисленные значения выводятся в поле характеристик текущего объекта.

Дополнительная информация о площадях и периметрах отдельных граней текущего многогранника доступна через услугу программы Вычисление\Многогранник\Площади и периметры граней. В появляющемся окне Перечень граней объекта приведен перечень граней текущего объекта-многогранника и перечни вершин, которые лежат на каждой отдельной грани, а также площади и периметры этих граней. Под перечнем в поле Площадь отмеченных выводится суммарная площадь граней, отмеченных "галочкой" в перечне граней. С помощью кнопок Отметить все, Снять отметки и Инвертировать отметки можно быстро отметить все грани, снять отметки со всех граней в перечне или изменить состояние отметок граней на противоположное.

Заметим, что услугой Вычисление\Многогранник\Площади и периметры граней можно воспользоваться лишь тогда, когда текущим объектом является объект типа Многогранник.


part10

10. Сечения многогранников плоскостями

В ППС GRAN-3D предусмотрено выполнение сечений выпуклых многогранников плоскостями. Напомним, что многогранник называется выпуклым, если он лежит по одну сторону от плоскости любой из своих граней. Для выполнения сечения предназначена услуга Операции\Выполнить сечение, после обращения к которой нужно указать в поле Изображения (с помощью указателя мыши) плоскость (объект типа Плоскость), которая сечет многогранник, и многогранник (объект типа Многогранник), который пересекается.

В случае утвердительного ответа на запрос "Создать ломаную, соответствующую контуру сечения?", который появится после указания плоскости и многогранника, будет создан соответствующий объект типа Ломаная.

Далее появится дополнительный запрос "Создать объекты, которые отвечают частям исходного многогранника в разных полупространствах относительно плоскости сечения?". В случае утвердительного ответа автоматически будут созданы два новых объекта типа Многогранник, которые будут иметь такое же название, как и базовый, но с пометками ч.1 и ч.2 соответственно, и будут соответствовать частям исходного объекта в разных полупространствах относительно плоскости сечения. В дальнейшем с вновь образовавшимися многогранниками можно оперировать как с отдельными объектами. В поле отчета появится площадь и длина периметра полученного сечения.

Следует подчеркнуть, что в программе предусмотрено выполнение сечений только выпуклых многогранников.


part11

11. Вычисление расстояний и углов

ППС GRAN-3D позволяет вычислять расстояния между двумя точками, между точкой и прямой, между двумя прямыми, между прямой и плоскостью, между точкой и плоскостью (при этом автоматически вычисляется и отклонение d точки от плоскости), а также вычислять углы (по трем точкам) между отрезками, которые имеют общую точку, между прямой и плоскостью и между двумя плоскостями. Для этого предназначены услуги пунктов меню Вычисление\Расстояние и Вычисление\Угол.

На соответствующие запросы программы (которые появляются в поле Подсказки) необходимо указать точки, прямые или плоскости (в зависимости от того, что нужно вычислить), после чего результат вычислений будет выведен в поле отчета.

Заметим, что:

  • "указать точку" означает подвести указатель мыши к изображению нужной точки в поле Изображения (так, чтобы в поле Информирования появились координаты выбранной точки и название объекта, которому эта точка принадлежит, а указатель мыши приобрел форму крестика со стрелкой) и нажать левую клавишу мыши;

  • "указать прямую" означает подвести указатель мыши к изображению отрезка, который определяет нужную прямую (так, чтобы отрезок стал пунктирным, в поле Информирования появилось название объекта, которому этот отрезок принадлежит, а указатель мыши приобрел форму крестика со стрелкой), и нажать левую клавишу мыши;

  • "указать плоскость" означает подвести указатель мыши к изображению объекта типа Плоскость (так, чтобы в поле Информирования появилось название этого объекта, а указатель мыши приобрел форму крестика со стрелкой), и нажать левую клавишу мыши.

Для вычисления длины любого отрезка (ребра многогранника, звена ломаной и т.п.) в поле изображения необходимо лишь подвести указатель мыши к изображению этого отрезка, и значение его длины появится в поле Информирования.

11.1. Вычисление расстояния между двумя точками

Для вычисления расстояния между двумя точками следует обратиться к услуге Вычисление\Расстояние\между двумя точками и указать две точки на изображении.

11.2. Вычисление расстояния между точкой и прямой

Для вычисления расстояния между точкой и прямой следует воспользоваться услугой Вычисление\Расстояние\между точкой и прямой и указать точку и прямую на изображении.

11.3. Вычисление расстояния между точкой и плоскостью

Для вычисления расстояния между точкой и плоскостью необходимо обратиться к услуге Вычисление\Расстояние\между точкой и плоскостью и указать точку и плоскость на изображении. При этом автоматически вычисляется и отклонение d точки от плоскости, абсолютное значение которого |d| и равняется расстоянию от точки до плоскости, а знак указывает на полупространство, в котором находится рассматриваемая точка относительно данной плоскости (ее вектора нормали).

11.4. Вычисление расстояния между двумя прямыми

Для вычисления расстояния между двумя прямыми следует обратиться к услуге Вычисление\Расстояние\между двумя прямыми и указать две прямые на изображении. Если указанные прямые пересекаются, в поле отчета будут выведены координаты точки их пересечения и появится запрос "Создать соответствующую точку? " с кнопками Да и Нет. При "нажатии" кнопки Да будет создан объект типа Точка, соответствующий точке пересечения прямых.

11.5. Вычисление расстояния между прямой и плоскостью

Для вычисления расстояния между прямой и плоскостью нужно обратиться к услуге Вычисление\Расстояние\между прямой и плоскостью и указать прямую и плоскость на изображении. Если указанные прямая и плоскость пересекаются, в поле отчета будут выведены координаты точки пересечения и появится запрос "Создать соответствующую точку?" с кнопками Да и Нет. При нажатии кнопки Да будет создан объект типа Точка, соответствующий точке пересечения указанных прямой и плоскости.

11.6. Вычисление угла между двумя отрезками, которые имеют общую точку

При обращении к услуге Вычисление\Угол\по трем точкам после указания в поле Изображения трех точек будет вычислен угол между прямыми, которые проходят соответственно через первую и вторую и вторую и третью точки.

11.7. Вычисление острого угла между прямой и плоскостью

Для вычисления острого (и прямого) угла между прямой и плоскостью нужно обратиться к услуге Вычисление\Угол\между прямой и плоскостью и указать в поле Изображения прямую и плоскость.

11.8. Вычисление острого угла между двумя плоскостями

Для вычисления острого (и прямого) угла между двумя плоскостями необходимо обратиться к услуге Вычисление\Угол\между двумя плоскостями и указать в поле Изображения две плоскости.


part12

12. Вычисление площадей поверхностей и ограниченных ими объемов

12.1. Услуга Вычисление\Поверхность\Объем и площадь

Программа GRAN-3D оснащена средствами приближенного вычисления двойных интегралов и площадей поверхностей, заданных совокупностью уравнений вида z=f(x,y), для каждого из которых указана область задания (Q) в виде системы неравенств или многоугольника в плоскости x0y. Причем область интегрирования (G) должна быть ограничена и входить в область задания поверхности. Область интегрирования G может быть задана или системой неравенств, или как многоугольник в плоскости xOy.

В окне Вычисление на вкладыше Двойной интеграл и площадь, которое появится после обращения к услуге Вычисление\Двойной интеграл и площадь поверхности, в поле Поверхность нужно указать название заранее созданного объекта типа Поверхность (см.§4.6), соответствующие объем и площадь поверхности которого нужно вычислить.

Если необходимо задать область интегрирования системой неравенств, то следует "нажать" кнопку Система неравенств под надписью Область интегрирования, после чего в поле G= нужно ввести (через запятую) соответствующие неравенства. Кроме того (в связи с особенностью реализации вычислений) в соответствующие поля (от x=, до х=, от y=, до y=) необходимо ввести пределы табулирования, которые должны быть такие, чтобы область интегрирования G помещалась внутри указанных пределов, не пересекая их.

Если необходимо задать область интегрирования, которая ограниченная некоторым многоугольником, то нужно "нажать" кнопку Многоугольник под надписью Область интегрирования, и последовательно ввести таблицу координат вершин многоугольника. При этом для добавления новой строки в таблицу следует "нажать" кнопку "+", а для удаления текущей строки - кнопку "-". Для очищения таблицы можно воспользоваться кнопкой с изображением чистого листа. Вершины многоугольника также можно задать "графически" ("с экрана"). Для этого следует "нажать" кнопку Графически и в появившемся окне Графическое задание многоугольника указать положения вершин соответствующего многоугольника с помощью мыши.

Для выполнения вычислений необходимо нажать кнопку Вычислить, после чего результат будет выведен в поле Результат вычислений.

Заметим, что процесс вычисления требует определенного времени, которое зависит от заданного количества точек деления области интегрирования при настройке программы (см.§16).


part13

13. Вычисление объемов и площадей поверхностей тел вращения

В программе предусмотрено вычисления объемов и площадей поверхностей тел вращения, образующие которых вращаются вокруг оси Оx или Oy в прямоугольной декартовой системе координат и задаются одним из трех способов:

1. в виде явной зависимости между переменными x и y: y=f(x);

2. в виде заданной параметрически зависимости между переменными x и y: x=f(t), y=g(t), где t - переменная-параметр;

3. в виде ломаной, заданной упорядоченным набором вершин в плоскости xOy.

Сразу после создания объекта типа Поверхность вращения (см.§4.7) начнется вычисление объема и площади поверхности тела, ограниченного поверхностью, образованной вращением графика заданной функции или ломаной. Этот процесс требует определенного времени, поэтому во время вычисления появляется окно с показателем состояния выполнения вычислений.

После вычисления результат будет выведен в поле характеристик текущего объекта.


part14

14. Вычисление значений выражений

Во время работы с программой иногда возникает необходимость вычислить значение некоторого выражения. В таких случаях удобно воспользоваться услугой Вычисление\Значение выражения. На вкладыше Значение выражения окна Вычисление, которое появится после обращения к указанной услуге, в поле Выражение нужно ввести выражение, значение которого необходимо вычислить, и "нажать" кнопку Вычислить, после чего результат будет выведен в поле Результат вычислений. При этом если выражение было введено некорректно, то появится сообщение об ошибке.

Для ввода выражений можно использовать панель калькулятора с цифровыми кнопками и кнопками быстрого ввода названий стандартных функций, что позволяет вводить выражения с помощью лишь мыши, без использования клавиатуры. Без использования панели калькулятора все необходимые символы можно ввести также и с клавиатуры.

Числовые значения и выражения следует записывать по тем же правилам, как и при вводе числовых значений и выражений во время работы с программами GRAN1, GRAN-2D (см.§3).


part15

15. Вычисление интегралов вдоль контура

Для приближенного вычисления криволинейного интеграла от некоторой функции вида z=f(x,y) вдоль контура в плоскости x0y или криволинейного интеграла от функции вида t=f(x,y,z) вдоль контура в пространстве можно воспользоваться услугой Вычисление\Интеграл вдоль контура.

На вкладыше Интеграл вдоль контура окна Вычисление, которое появится, необходимо указать тип подинтегральной функции с помощью переключателя Тип зависимости, после чего ввести выражение функции в поле возле надписи Выражение.

Контур может быть задан тремя способами:

1. в виде графика явной зависимости между переменными x и y: y=f(x);

2. в виде графика параметрически заданной зависимости между переменными x и y: x=f(t), y=g(t), где t - переменная-параметр;

3. в виде ломаной, заданной упорядоченным набором вершин.

Под надписью Тип контура размещены три кнопки с надписями, которые соответствуют каждому из возможных способов задания контура

  • Если контур определяется явной зависимостью между переменными x и y, то следует "нажать" кнопку График y=f(x) под надписью Тип контура, после чего в соответствующие поля ввести выражение зависимости и пределы изменения переменной x.

  • Если контур определяется параметрической зависимостью между переменными x и y, то нужно "нажать" кнопку График x=f(t), y=g(t) под надписью Тип контура, после чего в соответствующие поля ввести выражения зависимости и пределы для t.

  • Если контур определяется ломаной, то нужно "нажать" кнопку Ломаная под надписью Тип контура. Далее можно или выбрать в поле Ломаная название соответствующего (созданного заранее) объекта типа Ломаная (см.§4.3), или, "нажав" кнопку Графически, с помощью мыши указать "с экрана" вершины ломаной в появившемся окне Графическое задание ломаной.

После "нажатия" кнопки Выполнить результат будет выведен в поле Результат вычислений.


part16

16. Настройки программы

Программа оснащена средствами для изменения некоторых параметров работы. Для этого предназначены услуги пункта Настройки главного меню.

При обращении к пункту меню Настройки\Параметры появляется окно Настройки с вкладышами Изображение, Вычисление, Общие и Цвета. В нижней части окна размещены кнопки Запомнить, Отменить, Применить. При нажатии кнопки Запомнить указанное окно исчезнет, а все изменения, внесенные в настройки программы, будут задействованы. При нажатии кнопки Применить все изменения, внесенные в настройки программы, будут задействованы, но окно не исчезнет, то есть можно продолжать настраивать программу. Кнопка Отменить используется, если нет необходимости сохранять внесенные изменения в настройки программы.

На вкладыше Изображение в рамке Масштаб изображения можно установить соотношение коэффициентов масштабирования изображений объектов вдоль каждой из координатных осей в поле изображения. По умолчанию установлены пропорциональные коэффициенты, но если убрать отметку возле надписи Пропорционально, то в полях под указанной надписью можно ввести новые коэффициенты.

В рамке Центр поворота можно указать координаты центра поворота, вокруг которого будут вращаться изображения объектов и осей при использовании полос поворота изображения. По умолчанию центр поворота совпадает с началом координат, но если убрать отметку возле надписи Начало координат, то в полях под указанной надписью можно ввести новые координаты.

В рамке Координаты источников света (для полутонового режима) можно указать новые координаты двух источников рассеянного света, которые будут освещать изображение объектов в режиме полутонового изображения.

На вкладыше Вычисление в поле возле надписи Количество точек деления области интегрирования устанавливается значение, которое используется при вычислении значений интегралов по формулам численного интегрирования. Минимальное количество точек деления - 2, максимальное - 1000. Чем большее количество точек установлено, тем точнее будут вычислены значения интегралов, но и больше затрачено времени на вычисления.

Перемещением "ползунка" (с помощью мыши), находящегося возле надписи Качество изображения создаваемых поверхностей, можно изменить качество изображения объектов типа Поверхность. Чем выше качество выбрано, тем больше времени необходимо на вывод изображений объектов, но соответственно возрастет качество и точность изображения.

В поле возле надписи Количество цифр в ответах указывается количество цифр, которые будут выводиться на экран в результатах вычислений.

На вкладыше Общие путем установки или снятия отметки возле соответствующей надписи можно указать, нужно ли:

  • изображать вершины (узлы) объектов;

  • изображать проекции текущей точки на координатные плоскости;

  • изображать номера вершин объектов;

  • выводить латинские буквы вместо номеров вершин (только если отмечен пункт изображать номера вершин объектов);

  • выводить номер объекта (под которым он числится в перечне объектов) возле номера вершины (только если отмечен пункт Изображать номера вершин объектов);

  • изображать координатные оси;

  • удалять лишние линии граней выпуклых многогранников (поскольку при создании объекта грани делятся на треугольники, что несколько усложняет обзор изображения, в программе предусмотрена возможность при выводе изображения "объединять" треугольники, составляющие одну грань, в n-угольник);

  • автоматически загружать последний рабочий файл (при загрузке программы);

  • выводить путь к рабочему файлу в заголовке главного окна.

На вкладыше Цвета можно указать желаемые цвета некоторых элементов интерфейса программы. Названия всех элементов, цвет которых можно изменить, приведены в перечне. Для изменения цвета определенного элемента необходимо установить указатель перечня на название элемента (с помощью мыши или клавиш управления курсором) и указать на прямоугольник с необходимым цветом, размещенный справа от перечня.

При "нажатии" кнопки Восстановить стандартные установки для всех элементов перечня будут установлены цвета, заданные в программе по умолчанию.