First Topic

ППЗ GRAN-3D

1. Початок роботи з програмою. Звернення до послуг програми

1.1. Позначення, що використовуються в тексті

В тексті курсивом виділяються написи та послуги, що належать до інтерфейсу програми. Надалі вказати на деякий об'єкт чи послугу означатиме підвести вказівник мишки до відповідної назви чи зображення та натиснути ліву клавішу мишки. "Звернутися до послуги", "Активізувати послугу" означатиме встановити вказівник на назву потрібної послуги головного меню програми (за допомогою використання клавіш управління курсором або вказівника мишки) та натиснути клавішу Enter або ліву клавішу мишки. Запис у вигляді "звернутися до послуги Обчислення\Кут\за трьома точками" означатиме "звернутися до пункту головного меню Обчислення, далі до підпункту Кут, і потім до підпункту За трьома точками ".

1.2. Основні елементи інтерфейсу. Звернення до послуг програми

Після активізації ППЗ GRAN-3D на екрані з'явиться головне вікно програми. Зверху під заголовком головного вікна подано головне меню - перелік послуг, до яких можна звернутися в процесі роботи з програмою. При зверненні до певного пункту головного меню з'являється перелік пунктів (послуг) відповідного підменю. Пункти підменю в свою чергу можуть розгалужуватись на підпункти, перелік яких з'являється при зверненні до відповідного пункту підменю.

Під час роботи з програмою у деяких ситуаціях використання певних послуг меню не є коректним. Такі пункти виділятимуться блідішим кольором, а звернення до них не призведе до яких небудь дій. Наприклад, використання послуг пункту головного меню Об'єкт\Змінити чи Об'єкт\Вилучити на початку роботи з програмою, поки ще не створено жодного об'єкта, не є коректним, оскільки ще немає чого змінювати чи вилучати.

Якщо необхідно відмовитися від роботи із щойно обраною послугою, слід звернутися до послуги Об'єкт\Припинити виконання операції, або натиснути клавішу ESC.

Звернення до окремих послуг програми (без перебирання пунктів головного меню і підпунктів відповідних підменю) при необхідності можна здійснити за допомогою функціональних клавіш або комбінацій клавіш, вказаних справа біля назв пунктів головного меню.

1.2.1. Панель інструментів

Для активізації деяких послуг можна скористатись кнопками швидкого виклику операцій на панелі інструментів, що розміщена під головним меню програми. Для цього треба натиснути відповідну кнопку (тобто встановити вказівник мишки на позначення кнопки і натиснути ліву клавішу мишки). "Кнопки" оснащено системою оперативної підказки, тому під час знаходження вказівника мишки над певною "кнопкою" на екрані з'являються короткі відомості про призначення даної "кнопки".

1.2.2. Поле підказки

Під панеллю інструментів розміщено підказку - поле, де виводяться короткі повідомлення про те, яку дію необхідно виконати на поточному етапі роботи

1.2.3. Поле зображення

Поле зображення - частина головного вікна програми, де зображаються створені об'єкти та осі координат. З правого та нижнього краю цього поля розміщено смуги повороту зображення, за допомогою яких здійснюється поворот зображень об'єктів у полі зображення. При змінюванні положення вказівника вертикальної смуги повороту відбуватиметься поворот зображення навколо горизонталі, що проходить через центр повороту (центр повороту може знаходитись у будь-якій точці простору, а його координати можна встановити на вкладинці Загальні вікна Налагодження, див.§16), а при змінюванні положення вказівника горизонтальної смуги повороту відбуватиметься поворот зображення навколо осі 0Z. Щоб змінити положення вказівника смуги повороту, слід підвести до нього вказівник мишки, далі, натиснувши і утримуючи ліву клавішу мишки, перемістити вказівник у потрібне положення та відпустити ліву клавішу мишки.

1.2.4. Перелік об'єктів

Перелік об'єктів - поле, що містить перелік назв усіх об'єктів, які були створені або завантажені у процесі роботи з програмою (на початку роботи з програмою вказане поле не містить жодної назви). Об'єкт, на назві якого знаходиться вказівник, вважається поточним. Зміна положення вказівника поточного об'єкта здійснюється за допомогою вказівника мишки (слід вказати на назву об'єкта, який необхідно зробити поточним) або за допомогою клавіш управління курсором.

У полі зображення виводяться зображення лише тих об'єктів, перед назвою яких у переліку об'єктів стоїть відмітка ("галочка"). Щоб тимчасово вилучити чи вивести зображення об'єкта у поле зображення, необхідно підвести до квадратика зліва від назви відповідного об'єкта вказівник мишки та натиснути її ліву клавішу. Подвійне натиснення лівої клавіші мишки призведе до активізації послуги Об'єкт\Змінити стосовно даного об'єкта.

1.2.5. Поле характеристик об'єкта

Поле характеристик об'єкта - частина головного вікна, де виводяться деякі параметри поточного об'єкта: його назва, координати його крайніх вершин, кількість вершин.

1.2.6. Поле звіту

Поле звіту - частина головного вікна, де фіксується протокол роботи програми та куди виводяться результати усіх вимірювань та обчислень. Для очищення поля звіту потрібно звернутися до послуги головного меню Налагодження\Очистити звіт, або, встановивши вказівник мишки над цим полем, натиснути праву клавішу мишки і у випадаючому меню, що з'явиться, вибрати відповідну послугу.

1.2.7. Поле інформування

Поле інформування - поле (внизу екрану), де виводяться просторові координати точки, що відповідає поточному положенню вказівника мишки у полі зображення (якщо координати такої точки можна визначити однозначно), назва об'єкта, якому ця точка належить, довжина відрізка тощо. У полі інформування виводиться також коротка інформація про елементи інтерфейсу ППЗ GRAN-3D, над якими знаходиться вказівник мишки.


part2

2. Система координат. Картинна площина проекції

2.1. Зображення координатних осей. Масштаб зображення

Відразу після завантаження програми GRAN-3D у полі зображення з'являється зображення осей координат, на яких вказано значення поділок, що визначають довжини одиничних відрізків вздовж цих осей. Співвідношення масштабів зображення вздовж кожної з осей можна змінити за допомогою послуги Налагодження\Параметри на вкладинці Зображення вікна Налагодження (див.§16). Для збільшення або зменшення масштабу зображення призначено послуги Зображення\Збільшити та Зображення\Зменшити. Після звернення до послуги Зображення\Дібрати розмір буде встановлено передбачений в програмі масштаб зображення.

2.2. Поворот системи координат

За допомогою смуг повороту зображення можна повертати систему координат разом з створеними моделями об'єктів. Центром повороту може бути точка з довільними просторовими координатами (за замовчуванням центром повороту є точка з координатами (0,0,0)). Щоб змінити координати центра повороту, слід скористатися послугою Налагодження\Параметри на вкладинці Зображення вікна Налагодження (див.§16). Для повороту системи навколо осі Oz призначена горизонтальна смуга повороту зображення, а для повороту навколо горизонталі, що проходить через центр повороту, призначена вертикальна смуга повороту зображення. Для повороту системи можна використовувати також клавіші управління курсором.

2.3. Виродження простору у площину. Ізометрія

Для швидкого встановлення системи у положення ізометрії або в положення, при якому зображення однієї з координатних осей вироджується в точку, призначено послуги пункту Зображення\Положення координатних осей - Вироджена вісь Ox, Вироджена вісь Oy, Вироджена вісь Oz та Ізометрія.

2.4. Визначення координат точок

Якщо підвести вказівник мишки до будь-якої лінії довільного об'єкта, вказана лінія виділяється пунктиром і у полі інформування автоматично виводяться просторові координати точки, що відповідає поточному положенню вказівника, та назва об'єкта, якому ця точка належить. У випадку, коли систему розміщено таким чином, що одна з координатних осей вироджується в точку (тобто координатна площина, що визначається іншими двома осями, розміщена паралельно до площини зображення), за програмою автоматично обчислюються (і виводяться у полі інформування) координати точки, якій відповідає поточне положення вказівника мишки у площині зображення. Координата вздовж виродженої осі вважається невідомою.

2.5. Півтонове зображення об'єктів

Для унаочнення моделей стереометричних тіл зручно скористатися послугою програми Зображення\Режим півтонового зображення, що дозволяє отримувати "реалістичне" зображення моделей цих тіл, побудоване з врахуванням видимості ліній і площин.


New Topic

3. Введення виразів

3.1. Подання числових значень

Числові значення і вирази потрібно подавати за правилами, близькими до правил, прийнятих у найбільш поширених мовах програмування високого рівня (Basic, Pascal тощо).

У введених числових значеннях дробова частина, якщо вона є, відокремлюється від цілої частини крапкою (в тексті числа подаються за цими ж правилами).

3.2. Позначення арифметичних операцій

Арифметичні операції позначаються знаками:

+ - додавання,

- - віднімання,

* - множення,

/ - ділення,

^- піднесення до степеня.

3.3. Порядок виконання операцій

Порядок виконання операцій - загальноприйнятий. Щоб вказати бажаний порядок виконання операцій, можна скористатись дужками. Вираз, поданий у дужках, розглядається як єдине ціле і обчислюється в першу чергу. Вирази у дужках в свою чергу можуть містити вирази у дужках і т.д. Кожній відкриваючій (лівій) дужці повинна відповідати закриваюча (права) дужка.

3.4. Позначення деяких функцій

До виразів можуть бути включені позначення (що розглядаються як неподільні символи) деяких функцій. Перелік позначень допустимих функцій подано на панелі калькулятора:

Sin - sin (синус),

Cos - cos (косинус),

Tg - tg (тангенс),

Сtg - ctg (котангенс),

Asin - arcsin (арксинус),

Acos - arccos (арккосинус),

Atg - arctg (арктангенс),

Actg - arcctg (арккотангенс),

Exp - ex (експонента),

Ln - logex логарифм натуральний (за основою e),

Lg - log10x логарифм десятковий (за основою 10),

Sqrt -корінь квадратний,

Int - ціла частина аргументу,

Abs - абсолютне значення (модуль),

Pi - 3.141592654.

3.5. Введення виразів за допомогою мишки. Панель калькулятора

Панель калькулятора з цифровими кнопками та кнопками швидкого введення назв стандартних функцій дозволяє вводити вирази за допомогою лише мишки, без використання клавіатури. Для введення певного символу слід "натиснути" (за допомогою мишки) кнопку з піктограмою необхідного символу на панелі калькулятора. Без використання панелі калькулятора всі необхідні символи можна ввести з клавіатури.


part4

4. Створення моделей просторових об'єктів

4.1. Загальні відомості

ППЗ GRAN-3D дозволяє створювати та оперувати моделями геометричних об'єктів поданих нижче типів: точка, відрізок, ламана, площина, многогранник, поверхня обертання та довільна поверхня, що визначається рівнянням виду z=f(x,y). При цьому можливе задання об'єктів у різний спосіб.

Точка задається своїми просторовими координатами x, y та z, відрізок - двома точками або точкою і напрямним вектором, ламана - координатами вузлів або точкою та впорядкованим набором векторів (ламана може бути замкненою чи незамкненою), площина - трьома точками, точкою і вектором нормалі або коефіцієнтами A, B, C, D рівняння площини виду Ax+By+Cz+D=0.

Многогранник задається сукупністю граней, де кожна грань - трикутник, що визначається деякими трьома вершинами многогранника, а кожна вершина задається своїми просторовими координатами.

Поверхня - просторовий об'єкт, що описується сукупністю рівнянь виду z=f(x,y), для кожного з яких вказується область задання у вигляді системи нерівностей виду g(x,y)<=0 або як многокутник у площині xOy.

Поверхня обертання - поверхня, що утворюється обертанням навколо осі Ox або Oy деякої плоскої кривої чи ламаної, що лежать в площині xOy. При цьому криву можна задати аналітично явною залежністю між змінними x і y у вигляді y=f(x) або ж параметрично у вигляді x=f(t), y=g(t), а ламану можна задати або ввівши координати її вершин, або вказавши вершини на екрані за допомогою мишки.

Для створення деякого об'єкта слід звернутися до підпункту послуги Об'єкт\Створити, що має назву, яка відповідає бажаному типу об'єкта. В результаті з'явиться вікно Конструювання об'єкта, в якому на вкладинці з назвою типу створюваного об'єкта слід задати параметри об'єкта. Для об'єктів всіх типів можна вказати колір їх зображення та назву.

Після введення параметрів об'єкта, що створюється, слід натиснути кнопку Виконати. Зауважимо, що якщо введені параметри об'єкта не є коректними, кнопка Виконати буде недоступна, а у полі повідомлень (зліва біля кнопки Виконати) буде виведено відповідне повідомлення про помилку.

Після створення об'єкта його зображення (вказаного кольору) з'явиться у полі зображення, а його назва з'явиться у переліку об'єктів.

4.2. Створення об'єкта типу Точка

Для cтворення об'єкта типу Точка необхідно звернутись до послуги меню Об'єкт\Створити\Точка. У вікні Конструювання об'єкта, що з'явиться, на вкладинці Точка слід ввести просторові координати точки та натиснути кнопку Виконати.

4.3. Створення об'єкта типу Ламана

Якщо необхідно створити ламану (або відрізок), то слід звернутись до послуги меню Об'єкт\Створити\Ламана. У вікні Конструювання об'єкта, що з'явиться, на вкладинці Ламана слід задати параметри ламаної. За допомогою перемикача Спосіб задання слід вказати спосіб задання ламаної - за координатами вершин чи за координатами першої вершини та впорядкованого набору векторів, що визначатиме всі інші вершини. Далі слід вказати, якою має бути ламана: замкнена чи незамкнена (для цього потрібно за допомогою мишки встановити або зняти відмітку біля напису Замкнена).

В залежності від положення перемикача Спосіб задання слід ввести до таблиці координати вершин ламаної або координату першої вершини та впорядкований набір координат напрямних векторів, що вказують на вершини ламаної.

Щоб додати або вилучити поточний рядок таблиці, слід скористатись кнопками з зображенням "+" або "-", розміщених справа від таблиці. Кількість рядків таблиці вказує на кількість вершин ламаної. Для підтвердження введення даних слід натиснути кнопку Виконати.

4.4. Створення об'єкта типу Площина

Для cтворення об'єкта типу Площина необхідно звернутись до послуги меню Об'єкт\Створити\Площина. В результаті з'явиться вікно Конструювання об'єкта, в якому на вкладинці Площина слід вказати параметри площини.

Перш за все необхідно вказати спосіб задання площини: за трьома точками, за точкою та вектором нормалі або за коефіцієнтами A,B,C,D рівняння площини виду Ax+By+Cz+D=0 (скориставшись перемикачем Спосіб задання). Якщо обрано спосіб задання Три точки, у відповідні поля введення необхідно ввести просторові координати трьох точок, що визначатимуть площину. Якщо ж обрано спосіб задання Точка і вектор нормалі, у відповідні поля необхідно ввести просторові координати точки та вектора нормалі, що визначатимуть площину. У випадку, коли обрано спосіб задання Рівняння Ax+By+Cz+D=0, у відповідні поля введення необхідно ввести коефіцієнти A,B,C,D, що визначатимуть площину.

Для підтвердження введення даних слід натиснути кнопку Виконати. Площина зображатиметься у вигляді деякого трикутника з пунктирними сторонами. Якщо площина була задана за трьома точками, то ці три точки відповідатимуть вершинам трикутника на зображенні. У всіх інших випадках задання площини координати вершин трикутника добираються автоматично так, щоб трикутник належав площині та в той же час був розміщений найближче до початку координат.

4.5. Створення об'єкта типу Многогранник

Для cтворення об'єкта типу Многогранник потрібно звернутись до послуги меню Об'єкт\Створити\Многогранник, що призведе до появи вікна Конструювання об'єкта з вкладинкою Многогранник.

Засобами ППЗ GRAN-3D можна створити довільний многогранник. Для цього необхідно у відповідних полях вказати кількість вершин многогранника та кількість трикутних граней (не трикутні грані потрібно поділити на трикутники), ввести координати вершин многогранника у таблиці Вершини, а також вказати по три вершини на кожній грані.

Для опуклих многогранників можна не вказувати кількість трикутних граней та номери вершин для кожної грані. Досить спочатку ввести вершини многогранника, а потім скористатися послугою Сформувати грані опуклого об'єкта - кількість граней і відповідні номери вершин для кожної грані буде встановлено автоматично. Для підтвердження введення даних слід натиснути кнопку Виконати.

4.6. Створення об'єкта типу Поверхня

Щоб cтворити об'єкт типу Поверхня, необхідно звернутись до послуги меню Об'єкт\Створити\Поверхня, що призведе до появи вікна Конструювання об'єкта з вкладинкою Поверхня.

Поверхня описується сукупністю рівнянь виду z=f(x,y), для кожного з яких вказується область задання у вигляді системи нерівностей виду g(x,y)<=0 або як многокутник у площині xOy. Області задання "фрагментів" поверхні не повинні перетинатись.

Під написом Частини поверхні та їх області задання наведено перелік фрагментів, що складають поверхню (спочатку в переліку є лише один фрагмент). Поточний фрагмент виділений темним прямокутником. Щоб додати фрагмент, слід "натиснути" кнопку "+" (справа від переліку), а щоб вилучити поточний фрагмент, слід "натиснути" кнопку "-".

У полі біля напису z(x,y)= необхідно ввести аналітичний вираз від аргументів x та y, що описує поточний фрагмент поверхні (наприклад, sin(x+y)).

Під написом Спосіб вказування області задання розміщено кнопки Система нерівностей та Многокутник. В залежності від того, яким чином зручніше вказувати область задання поточного фрагмента поверхні, слід "натиснути" кнопку з відповідним написом.

Якщо обрано спосіб вказування області задання у вигляді системи нерівностей, то у полі біля напису Q= слід ввести нерівність або систему нерівностей (нерівності одна від одної відокремлюються комою), що описують область задання поточного фрагмента поверхні (наприклад, x>0,y<5 або x^2+y^2<4^2 тощо). Якщо вказане поле залишити порожнім, то область задання буде необмежена.

Якщо встановлено спосіб вказування області задання у вигляді многокутника, то слід ввести координати кожної вершини многокутника, що обмежує область задання поточного фрагмента поверхні, у таблицю. При цьому для додавання нового рядка до таблиці слід "натиснути" кнопку "+", а для вилучення поточного рядка - кнопку "-". Для очищення таблиці доцільно скористатися кнопкою з зображенням чистого аркуша

Вершини многокутника також можна задати "графічно" з екрана (вказавши їх положення за допомогою мишки). Для цього слід "натиснути" кнопку Графічно і у вікні Графічне задання многокутника, що з'явиться, вказати вершини відповідного многокутника.

У рамці Межі табулювання (для зображення) у відповідних полях слід вказати межі області табулювання поверхні, що використовуються при побудові її зображення. Зображення створеної поверхні буде складатися лише з тих фрагментів поверхні, що визначені як в області задання, так і в області табулювання.

4.7. Створення об'єкта типу Поверхня обертання

Для того, щоб досліджувати поверхню обертання за допомогою ППЗ GRAN-3D, необхідно створити відповідну їй модель - об'єкт типу Поверхня обертання. Для цього слід звернутися до послуги головного меню програми Об'єкт\Створити\Поверхня обертання. У вікні Конструювання об'єкта з вкладинкою Поверхня обертання, що з'явиться, слід вказати тип залежності, що описує твірну (твірна - плоска крива в площині xOy, обертанням якої навколо обраної осі утворюється поверхня), та параметри твірної, що утворюватиме поверхню обертання.

Перш за все, скориставшись перемикачем Тип залежності, необхідно обрати тип задання твірної. Якщо обрано тип y=f(x), то у полі введення біля напису y= слід ввести вираз від аргументу x, а у полях біля написів від x= та до x= потрібно вказати межі допустимих значень аргументу х.

Якщо обрано тип x=f(t), y=g(t), то у поля біля написів x= та y= слід ввести вирази від аргументу t, а у поля введення біля написів від t= та до t= вказати межі допустимих значень аргументу t.

Якщо обрано тип Ламана, тоді слід задати ламану-твірну у площині xOy, причому ламану можна задати або ввівши координати її вершин у відповідну таблицю, або графічно. В останньому випадку потрібно натиснути кнопку Графічно>>> та у вікні Графічне задання ламаної, що з'явиться, за допомогою мишки вказати вершини ламаної.

Після задання твірної необхідно вибрати вісь (Ox або Oy), навколо якої буде здійснюватись обертання твірної (за допомогою перемикача Обертання навколо осі).

Для зручності під час введення виразів автоматично здійснюється синтаксичний контроль введеного запису, тому в разі некоректного введення виразу відразу ж виводиться (у полі повідомлень) відповідне повідомлення про помилку, а введений запис зображається червоним кольором. У правій частині вікна виводиться зображення твірної у площині x0y.

За бажанням можна вказати вектор перенесення, на який буде після створення переміщено поверхню обертання відносно центра координат. Для підтвердження введення даних слід натиснути кнопку Виконати.

4.8. Графічне задання об'єктів типу Точка, Ламана, Площина

Об'єкти типу Точка, Ламана та Площина можна задавати з екрана графічно, вказавши точки, що визначають ці об'єкти, безпосередньо у полі зображення за допомогою мишки. Для створення об'єктів вказаних типів описаним способом слід звернутися до послуги меню Oб'єкт\Створити з екрану\Точка, Oб'єкт\Створити з екрану\Ламана або Oб'єкт\Створити з екрану\Площина, в залежності від того, об'єкт якого типу необхідно створити. За відповідним запитом програми, що з'явиться у полі підказки, необхідно у полі зображення вказати (за допомогою вказівника мишки) точки, що визначатимуть об'єкт, після чого у вікні Конструювання об'єкта, що з'явиться (після вказування останньої точки), відкоригувати деякі параметри об'єкта (якщо це необхідно) і натиснути кнопку Виконати.

Для створення об'єкта типу Точка слід вказати лише одну точку.

Для створення об'єкта типу Ламана слід вказати стільки точок, скільки вершин має ламана. Задавши останню вершину ламаної, слід натиснути праву кнопку мишки.

Для створення об'єкта типу Площина слід вказати три точки, через які має проходити площина.

"Вказати точку" означає підвести вказівник мишки у полі зображення до зображення будь-якої вершини або лінії (ребра) будь-якого створеного об'єкта так, щоб у полі інформування з'явилися координати точки та назва об'єкта, якому вона належить, та натиснути ліву клавішу мишки. Якщо одна з координатних площин розміщена (за допомогою смуг повороту зображення) паралельно до площини зображення, тоді слід курсор мишки підвести до будь-якої точки площини так, щоб у полі інформування з'явилися координати цієї точки, та натиснути ліву клавішу мишки. При створенні координата точки вздовж виродженої осі вважатиметься рівною 0.

4.9. Зміна параметрів об'єктів

Якщо виникла необхідність змінити параметри раніше створеного об'єкта, необхідно встановити вказівник переліку об'єктів у положення, що відповідає назві потрібного об'єкта, та звернутися до послуги Об'єкт\Змінити. В результаті з'явиться вікно Конструювання об'єкта з параметрами поточного об'єкта, які можна змінити так само, як при створенні цього об'єкта.

4.10. Вилучення об'єкта

Для вилучення деякого об'єкта потрібно встановити вказівник переліку об'єктів у положення, що відповідає назві цього об'єкта, та звернутися до послуги програми Об'єкт\Вилучити (або натиснути клавішу Del).


part5

5. Створення моделей базових просторових об'єктів

Моделі базових просторових об'єктів, якими оперують у школі при вивченні стереометрії (правильна звичайна або зрізана піраміда, правильна призма, прямий паралелепіпед, конус, циліндр, куля, куб) можна створювати окремо, вказавши лише необхідні параметри об'єкта у вікні Задання базових просторових об'єктів на вкладинці з відповідною назвою, що з'являється при зверненні до послуги програми Об'єкт\Створити базовий об'єкт.

5.1. Створення прямого паралелепіпеда

Вкладинка Прямий паралелепіпед містить засоби для задання прямих паралелепіпедів. За допомогою перемикача Основа слід встановити тип задання основи паралелепіпеда та ввести відповідні значення у поля введення під вказаним перемикачем. Також слід вказати висоту або об'єм тіла (в залежності від положення лівого перемикача). Ввівши всі необхідні дані, слід натиснути кнопку Створити.

5.2. Створення конуса

Для створення моделі конуса на вкладинці Конус слід вказати спосіб задання нижньої основи (за допомогою перемикача Нижня основа) та ввести значення відповідної величини у поле під вказаним перемикачем (якщо необхідно створити зрізаний конус, то слід встановити відмітку біля напису Зрізаний та аналогічно до попереднього задати верхню основу). Крім того слід вказати висоту або довжину твірної конуса (в залежності від положення лівого перемикача). Після введення даних слід натиснути кнопку Створити.

5.3. Створення циліндра

Для створення моделі циліндра на вкладинці Циліндр слід вказати спосіб задання основи (за допомогою перемикача Основа) та ввести значення відповідної величини у поле під перемикачем. Крім того слід вказати висоту або об'єм циліндра (в залежності від положення лівого перемикача). Після введення даних слід натиснути кнопку Створити.

5.4. Створення кулі

Для створення моделі кулі на вкладинці Куля слід вказати спосіб задання кулі (за допомогою перемикача Спосіб задання кулі) та ввести значення відповідної величини у поле під перемикачем, а також координати центра кулі. Після введення даних слід натиснути кнопку Створити.

5.5. Створення куба

На вкладинці Куб розміщено засоби для спрощеного створення моделі куба. Вказавши спосіб задання куба (за допомогою перемикача Спосіб задання куба) та ввівши відповідне значення у поле під перемикачем, слід натиснути кнопку Створити.

5.6. Створення правильної піраміди

Для створення моделі правильної піраміди на вкладинці Правильна піраміда слід вказати спосіб задання нижньої основи (за допомогою перемикача Нижня основа) та ввести відповідне значення у поле під вказаним перемикачем (якщо необхідно створити зрізану піраміду, то слід встановити відмітку біля напису Зрізана та аналогічно до попереднього задати параметри верхньої основи). Також слід вказати кількість вершин в основі піраміди та висоту або довжину бічного ребра піраміди (в залежності від положення лівого перемикача). Після введення даних слід натиснути кнопку Створити.

5.7. Створення правильної призми

Вкладинка Правильна призма призначена для створення моделі прямої правильної призми. Для створення призми необхідно вказати спосіб задання основ (за допомогою перемикача Задання основ) та ввести значення відповідної величини у поле під перемикачем, вказати висоту або об'єм призми (в залежності від положення лівого перемикача), а також вказати кількість вершин в основі призми. Після введення даних слід натиснути кнопку Створити.

Незалежно від того, який базовий об'єкт створюється, після натиснення кнопки Створити з'являється вікно Конструювання об'єкта з вкладинкою, що відповідає типу створюваного об'єкта, на якій вже заповнено всі необхідні поля даних для створення об'єкта (див.§4). За бажанням можна змінити колір, назву або інші параметри створюваного об'єкта. Після натиснення кнопки Виконати відповідний об'єкт буде створено.


part6

6. Збереження, завантаження та вилучення створених об'єктів

6.1. Збереження створених об'єктів

Для збереження створених об'єктів у файлі на зберігаючому пристрої слід звернутися до послуги головного меню Файл\Зберегти. Якщо об'єкти зберігаються вперше, то на запит програми у стандартному вікні збереження файлів системи Windows необхідно вказати ім'я файлу та цільовий каталог.

У разі виникнення необхідності зберегти об'єкти, що вже раніше зберігалися, у файлі з іншою назвою, слід скористатись послугою головного меню Файл\Зберегти як, що призведе до появи стандартного запиту Windows, де необхідно вказати нове ім'я файлу та цільовий каталог.

6.2. Завантаження створених об'єктів

Для завантаження раніше збережених об'єктів призначена послуга Файл\Завантажити. На стандартний запит системи, що з'явиться при зверненні до вказаної послуги, необхідно вказати ім'я файлу, в якому було збережено об'єкти.

Якщо потрібно завантажити не всі об'єкти з файлу, а лише деякі з них, то можна скористатися послугою Файл\Завантажити вибірково. Після вказування імені файлу (за запитом програми) з'являється вікно з переліком всіх об'єктів, що містяться у даному файлі. Необхідно поставити відмітки (за допомогою мишки) біля назв тих об'єктів у переліку, які необхідно завантажити. Якщо поставити відмітку біля напису додати до вже створених, вказані об'єкти буде додано до об'єктів, створених під час поточного сеансу роботи з програмою. В іншому випадку всі раніше створені об'єкти буде вилучено. Відмітка біля напису параметри з файлу вказує на те, чи необхідно завантажувати інформацію про положення координатних осей та масштаб зображення з вибраного файлу. Після натиснення кнопки Завантажити відмічені об'єкти буде завантажено.

Ім'я робочого файлу (тобто файлу, в якому збережено або з якого завантажено об'єкти) виводитиметься у заголовку головного вікна програми (якщо у параметрах налагодження програми встановлено опцію Виводити шлях до робочого файлу в головному вікні).

6.3. Вилучення створених об'єктів

Звернення до послуги головного меню Файл\Новий призведе до вилучення всіх раніше створених об'єктів та очищення поля звіту, тобто буде виконано підготовку до нового сеансу роботи.

6.4. Завершення роботи з програмою

Для завершення роботи з програмою необхідно звернутися до пункту меню Файл\Вихід. Якщо під час роботи з програмою було створено об'єкти, що не були збережені у файлі, то з'явиться повідомлення, у якому буде запропоновано зберегти об'єкти.


part7

7. Xарактеристики об'єктів

7.1. Характеристики поточного об'єкта

Деякі характеристики об'єктів обчислюються автоматично відразу після створення об'єктів або після їх перетворення. Для об'єктів всіх типів обчислюються (та виводяться у полі характеристик) координати "найвищих" та "найнижчих" точок вздовж кожної з координатних осей. Крім цього, для об'єктів кожного окремого типу виводиться деяка додаткова інформація:

  • для об'єктів типу Ламана обчислюється довжина ламаної, а якщо ламана замкнена і всі її вузли належать одній площині, то також обчислюється площа області, обмеженої ламаною;

  • для об'єктів типу Площина, незалежно від способу її задання, обчислюються коефіцієнти A, B, C і D рівняння площини виду Ax+By+Cz+D=0;

  • для об'єктів типу Многогранник обчислюється об'єм та площа поверхні, а також площа і периметр окремо кожної грані (ці характеристики наведено у вікні Перелік граней об'єкта, що з'явиться після звернення до послуги Обчислення\Многогранник\Площі та периметри граней);

  • для об'єктів типу Поверхня можливе обчислення об'ємів та площ поверхонь тіл, що ними обмежуються (ці відомості доступні через послугу головного меню Обчислення\Подвійний інтеграл та площа поверхні);

  • для об'єктів типу Поверхня обертання обчислюються площа поверхні, утвореної обертанням графіка деякої функції або ламаної, та обчислюється об'єм тіла, обмеженого такою поверхнею.


part8

8. Перетворення об'єктів

ППЗ GRAN-3D дозволяє здійснювати паралельне перенесення, поворот та деформацію об'єктів. Для цього призначено послуги пункту головного меню Операції.

Послугою Операції\Перетворення об'єктів можна скористатися в разі необхідності виконати паралельне перенесення, поворот або зміну розмірів поточного об'єкта. У вікні Операції над об'єктом з вкладинками Паралельне перенесення, Поворот та Деформація, що з'явиться після активізації вказаного пункту меню, слід перейти на вкладинку з назвою необхідної операції і, задавши параметри операції, натиснути кнопку Виконати.

8.1. Перетворення Паралельне перенесення

Для виконання паралельного перенесення поточного об'єкта на деякий вектор (a,b,c) необхідно перейти на вкладинку Паралельне перенесення. У поля біля написів a=, b=, c= необхідно ввести координати вектора і натиснути кнопку Виконати. У разі повторного натискання вказаної кнопки буде ще раз виконано паралельне перенесення поточного об'єкта на заданий вектор. Слід зауважити, що послуга не застосовується до об'єктів типу Поверхня.

8.2. Перетворення Поворот

Якщо необхідно виконати поворот поточного об'єкта на деякий кут навколо осі Ox, Oy або Oz, потрібно перейти на вкладинку Поворот. За допомогою перемикача Навколо осі необхідно вказати вісь, навколо якої потрібно здійснити поворот, а також ввести величину кута повороту (в градусах) у поле біля відповідного напису. Після натиснення кнопки Виконати операцію повороту буде застосовано до поточного об'єкта. Послуга не застосовується до об'єктів типу Поверхня та Поверхня обертання.

8.3. Перетворення Деформація

У разі необхідності збільшити або зменшити розміри об'єкта вздовж напряму осей Ox, Oy, Oz, слід перейти (за допомогою мишки) до вкладинки Деформація. У поля біля відповідних написів необхідно ввести коефіцієнти деформації вздовж кожного з напрямів Ox, Oy, Oz.

Після натиснення кнопки Виконати x-, y- та z-координати усіх точок поточного об'єкта буде помножено на відповідні коефіцієнти. Якщо значення коефіцієнта знаходиться в межах від 0 до 1, то розміри об'єкта будуть зменшуватись вздовж відповідного напрямку, якщо ж він більший від одиниці - то збільшуватись. Якщо коефіцієнт від'ємний, тоді окрім зміни розмірів відбувається також відображення об'єкта відносно відповідної площини.

За замовчуванням значення коефіцієнтів деформації вздовж кожної з осей встановлюються рівними 1.

Послуга не застосовується до об'єктів типу Поверхня та Поверхня обертання.

8.4. "Ручне" перетворення об'єктів

У випадку, коли осі координат у полі зображення встановлено (за допомогою смуг повороту зображення) у таке положення, що зображення однієї з осей вироджується в точку, тобто одна з координатних площин розмістилась паралельно до площини зображення, можливе виконання операцій над об'єктами "вручну". Для цього призначено послуги пункту меню Операції - Паралельне перенесення, Поворот, Зміна розмірів та Зміна форми.

8.4.1. Паралельне перенесення

Паралельне перенесення - послуга використовується, коли необхідно виконати перенесення деякого об'єкта паралельно до площини зображення (тобто у площині xОy, xОz або yОz, в залежності від того, яка з осей вироджена). Навівши вказівник мишки на зображення необхідного об'єкта так, щоб у полі інформування з'явилась назва цього об'єкта, і натиснувши ліву кнопку мишки (та тримаючи її у натисненому стані), потрібно рухати мишкою у потрібному напрямку. При цьому об'єкт буде рухатись разом з вказівником мишки. Після звільнення лівої клавіші мишки об'єкт буде зафіксовано у новому положенні у просторі. Послуга не застосовується до об'єктів типу Поверхня.

8.4.2. Поворот

Поворот - послуга використовується, коли необхідно виконати поворот деякого об'єкта навколо напряму виродженої осі. Встановивши вказівник мишки на зображення потрібного об'єкта (так, щоб у полі інформування з'явилась назва цього об'єкта) і натиснувши ліву клавішу мишки (та тримаючи її у натисненому стані), слід переміщувати вказівник мишки у напрямку повороту - об'єкт буде повертатись (відносно деякої точки всередині об'єкта) в одну або іншу сторону на кут, що визначається положенням вказівника мишки відносно деякої точки всередині. Після звільнення лівої клавіші мишки об'єкт буде зафіксовано у новому положенні.

Послуга не застосовується до об'єктів типу Точка, Поверхня та Поверхня обертання.

8.4.3. Зміна розмірів

Зміна розмірів - послуга використовується, коли необхідно виконати деформування (збільшення або зменшення розмірів вздовж одного із напрямів невироджених осей) деякого об'єкта. Встановивши вказівник мишки на зображення необхідного об'єкта (так, щоб у полі інформування з'явилася назва цього об'єкта) і натиснувши ліву клавішу мишки (та тримаючи її у натисненому стані), слід перемістити вказівник мишки у потрібному напрямку - об'єкт буде збільшуватись або зменшуватись вздовж однієї чи обох координатних осей відповідно до поточного положення вказівника мишки відносно деякої точки всередині об'єкта. Після звільнення лівої клавіші мишки буде зафіксовано об'єкт нових розмірів.

Послуга не застосовується до об'єктів типу Точка, Поверхня та Поверхня обертання.

8.4.4. Зміна форми

Зміна форми - послуга використовується, коли необхідно виконати перенесення паралельно до площини xОy, xОz або yОz (площини, паралельної площині зображення) однієї з вершин деякого об'єкта типу Точка, Ламана або Многогранник.

Встановивши вказівник мишки на зображення потрібної вершини об'єкта (так щоб у рядку інформування з'явилась назва цього об'єкта і вершина, яку необхідно перемістити, "підсвітилася") і натиснувши ліву клавішу мишки (та тримаючи її у натисненому стані), слід перемістити вказівник мишки так, щоб зафіксована вершина перемістилася у потрібне положення (зафіксована вершина переміщуватиметься разом з вказівником мишки). Після звільнення лівої клавіші мишки вибрана вершина об'єкта буде зафіксована у новому положенні у просторі. Послуга не застосовується до об'єктів типу Поверхня та Поверхня обертання.

Іноді в результаті виконання описаної операції стосовно об'єкта типу Многогранник може виникнути ситуація, коли даний об'єкт перестає бути коректно заданим (наприклад, через перенесення однієї з вершин відбулося "перехрещення" кількох граней). В цьому випадку з'явиться відповідне повідомлення і буде запропоновано відкоригувати об'єкт у вікні Конструювання об'єкта.


part9

9. Обчислення об'ємів та площ поверхонь многогранників

Об'єми та площі поверхонь об'єктів типу Многогранник (піраміда, призма, паралелепіпед, куб тощо) обчислюються за програмою автоматично при створенні або перетворенні цих об'єктів. Обчислені значення виводяться у полі характеристик поточного об'єкта.

9.1. Послуга Обчислення\Многогранник\Площі та периметри граней

Додаткова інформація про площі та периметри окремих граней поточного многогранника доступна через послугу програми Обчислення\Многогранник\Площі та периметри граней. У вікні Перелік граней об'єкта, що з'явиться, наведено перелік граней поточного об'єкта-многогранника та переліки вершин, що належать кожній окремій грані, а також площі та периметри цих граней. Під переліком у полі Площа відмічених виводиться сумарна площа відмічених ("галочкою") у переліку граней. За допомогою кнопок Відмітити всі, Зняти відмітки та Інвертувати відмітки можна швидко відмітити всі грані, зняти відмітки з усіх граней в переліку або змінити стан відміток граней на протилежний.

Зауважимо, що послугою Обчислення\Многогранник\Площі та периметри граней можна скористатися лише тоді, коли поточним об'єктом є об'єкт типу Многогранник.


part10

10. Перерізи многогранників площинами

10.1. Послуга Операції\Виконати переріз

ППЗ GRAN-3D дозволяє виконувати перерізи опуклих многогранників площиною. Нагадаємо, що многогранник називається опуклим, якщо він лежить по один бік від площини кожної з своїх граней. Для виконання перерізу призначено послугу Операції\Виконати переріз. Необхідно вказати у полі зображення (за допомогою вказівника мишки) площину (об'єкт типу Площина), якою перерізається многогранник, та многогранник (об'єкт типу Многогранник), що перерізається.

У разі позитивної відповіді на запит "Створити ламану, що відповідає контуру перерізу?", що з'явиться після вказування площини та многогранника, буде створено об'єкт типу Ламана, що відповідатиме контуру перерізу.

Далі з'явиться додатковий запит "Створити об'єкти, що відповідають частинам вихідного многогранника у різних півпросторах відносно площини перерізу?". У разі стверджувальної відповіді автоматично буде створено два нових об'єкти типу Многогранник, що матимуть таку ж назву, як і базовий, але з помітками ч.1 та ч.2 відповідно, та відповідатимуть частинам вихідного об'єкта у різних півпросторах відносно площини перерізу. Надалі новоутвореними многогранниками можна оперувати, як окремими об'єктами. У полі звіту з'явиться площа та довжина периметра утвореного перерізу.

Слід наголосити, що програма дозволяє виконувати переріз лише опуклих многогранників.


part11

11. Обчислення відстаней та кутів

ППЗ GRAN-3D дозволяє обчислювати відстані між двома точками, між точкою та прямою, між двома прямими, між прямою і площиною, між точкою і площиною (при цьому автоматично обчислюється й відхилення d точки від площини), а також обчислювати кути за трьома точками (між відрізками, що мають спільну точку), між прямою і площиною та між двома площинами. Для цього призначено послуги пунктів меню Обчислення\Відстань та Обчислення\Кут.

За відповідними запитами програми (що з'являться у полі підказки) необхідно вказати точки, прямі або площини (в залежності від того, що обчислюється), після чого результат обчислень буде виведено у поле звіту.

Надалі:

  • "вказати точку" означає підвести вказівник мишки до зображення потрібної точки у полі зображення (так, щоб у полі інформування з'явилися координати вибраної точки і назва об'єкта, якому ця точка належить, а вказівник мишки набув форми хрестика зі стрілкою) і натиснути ліву клавішу мишки;

  • "вказати пряму" означає підвести вказівник мишки до зображення відрізка, що визначає потрібну пряму (так, щоб відрізок зобразився пунктиром, у полі інформування з'явилася назва об'єкта, якому цей відрізок належить, а вказівник мишки набув форми хрестика зі стрілкою), і натиснути ліву клавішу мишки;

  • "вказати площину" означає підвести вказівник мишки до зображення об'єкта типу Площина (так, щоб у полі інформування з'явилася назва цього об'єкта, а вказівник мишки набув форми хрестика зі стрілкою), і натиснути ліву клавішу мишки.

Для обчислення довжини будь-якого відрізка (ребра многогранника, ланки ламаної тощо) у полі зображення необхідно лише навести вказівник мишки на зображення цього відрізка, і значення його довжини з'явиться у полі інформування.

11.1. Обчислення відстані між двома точками

Для обчислення відстані між двома точками слід звернутися до послуги Обчислення\Відстань\між двома точками та вказати дві точки на зображенні.

11.2. Обчислення відстані між точкою та прямою

Для обчислення відстані між точкою та прямою слід скористатися послугою Обчислення\Відстань\між точкою і прямою та вказати точку і пряму на зображенні.

11.3. Обчислення відстані між точкою та площиною

Для обчислення відстані між точкою та площиною необхідно звернутися до послуги Обчислення\Відстань\між точкою і площиною та вказати точку і площину на зображенні. При цьому автоматично обчислюється й відхилення d точки від площини, абсолютне значення якого |d| дорівнює відстані від точки до площини, а знак вказує на півпростір, у якому знаходиться розглядувана точка відносно обраної площини.

11.4. Обчислення відстані між двома прямими

Для обчислення відстані між двома прямими слід звернутися до послуги Обчислення\Відстань\між двома прямими та вказати дві прямі на зображенні. Якщо вказані прямі перетинаються, у поле звіту буде виведено координати точки перетину, та з'явиться запит "Створити відповідну точку?" з кнопками Так та Ні. У разі натиснення кнопки Так буде створено об'єкт типу Точка, що відповідатиме точці перетину прямих.

11.5. Обчислення відстані між прямою і площиною

Для обчислення відстані між прямою і площиною потрібно звернутися до послуги Обчислення\Відстань\між прямою і площиною та вказати пряму та площину на зображенні. Якщо вказані пряма та площина перетинаються, у поле звіту буде виведено координати точки перетину, та з'явиться запит "Створити відповідну точку?" з кнопками Так та Ні. У разі натиснення кнопки Так буде створено об'єкт типу Точка, що відповідатиме точці перетину вказаних прямої та площини.

11.6. Обчислення кута між двома відрізками, що мають спільну точку

При зверненні до послуги Обчислення\Кут\за трьома точками після вказування у полі зображення трьох точок буде обчислено кут між прямими, що проходять відповідно через першу і другу та другу і третю точки.

11.7. Обчислення гострого кута між прямою і площиною

Для обчислення гострого (і прямого) кута між прямою і площиною потрібно звернутися до послуги Обчислення\Кут\між прямою і площиною та вказати у полі зображення пряму та площину.

11.8. Обчислення гострого кута між двома площинами

Для обчислення гострого (і прямого) кута між двома площинами необхідно звернутися до послуги Обчислення\Кут\між двома площинами та вказати у полі зображення дві площини.


part12

12. Обчислення площ поверхонь та обмежених ними об'ємів

12.1. Послуга Обчислення\Поверхня\Об'єм та площа

Програму GRAN-3D оснащено засобами наближеного обчислення інтегралів виду та площ поверхонь, заданих сукупністю рівнянь виду z=f(x,y), для кожного з яких вказано область задання (Q) у вигляді системи нерівностей або як многокутника у площині x0y. Причому область інтегрування (G) повинна бути обмежена та належати області задання поверхні. Область інтегрування G може бути заданою або системою нерівностей, або як многокутник в площині xOy.

У вікні Обчислення на вкладинці Подвійний інтеграл та площа, що з'явиться після звернення до послуги Обчислення\Подвійний інтеграл та площа поверхні, у полі Поверхня потрібно вказати назву заздалегідь створеного об'єкта типу Поверхня (див.§4), подвійний інтеграл та площу поверхні якого потрібно обчислити.

Якщо необхідно задати область інтегрування системою нерівностей, то слід "натиснути" кнопку Система нерівностей під написом Область інтегрування, після чого у поле G= потрібно ввести (через кому) відповідні нерівності. Також (в зв'язку з особливістю комп'ютерної реалізації обчислень) у відповідні поля (від x=, до х=, від y=, до y=) необхідно ввести межі табулювання, які мають бути такі, щоб область інтегрування G містилася всередині вказаних меж, не перетинаючи їх.

Якщо необхідно задати область інтегрування, що обмежена деяким многокутником, то потрібно "натиснути" кнопку Многокутник під написом Область інтегрування, та послідовно ввести до таблиці координати вершин многокутника. При цьому для додавання нового рядка до таблиці слід "натиснути" кнопку "+", а для вилучення поточного рядка - кнопку "-". Для очищення таблиці доцільно скористатися кнопкою з зображенням чистого аркуша. Вершини многокутника також можна задати "графічно" ("з екрану"). Для цього слід "натиснути" кнопку Графічно і у вікні Графічне задання многокутника, що з'явиться, вказати положення вершин відповідного многокутника за допомогою мишки.

Для виконання обчислень необхідно натиснути кнопку Обчислити, після чого результати буде виведено у поле Результат обчислень.

Зауважимо, що процес обчислення вимагає певного часу, що залежить від обраної кількості точок поділу області інтегрування при налагодженні програми (див.§16).


part13

13. Обчислення об'ємів та площ поверхонь тіл обертання

В програмі GRAN-3D передбачено обчислення об'ємів та площ поверхонь тіл обертання, твірні яких обертаються навколо осі Оx або Oy у прямокутній декартовій системі координат та задаються одним із трьох способів:

  • у вигляді явної залежності між змінними x і y: y=f(x);

  • у вигляді параметрично заданої залежності між змінними x і y: x=f(t), y=g(t), де t - змінна-параметр;

  • у вигляді плоскої ламаної, що задається впорядкованим набором вершин у площині xOy.

Відразу після створення об'єкта типу Поверхня обертання (див.§4.7) розпочнеться обчислення об'єму та площі поверхні тіла, обмеженого поверхнею, утвореною обертанням графіка заданої функції або ламаної. Цей процес вимагає певного часу, тому під час обчислення з'являється вікно з показником стану виконання обчислень.

Після обчислення результат буде виведено у поле характеристик поточного об'єкта.


part14

14. Обчислення значень виразів

14.1. Послуга Обчислення\Значення виразу

Під час роботи з програмою іноді виникає необхідність обчислення значення деякого виразу. У таких випадках зручно скористатися послугою Обчислення\Значення виразу. На вкладинці Значення виразу вікна Обчислення, що з'явиться після звернення до вказаної послуги, у поле Вираз потрібно ввести вираз, значення якого необхідно обчислити, та "натиснути" кнопку Обчислити, після чого результат буде виведено у поле Результат обчислень. При цьому якщо вираз було введено некоректно, то з'явиться повідомлення про помилку.

При введенні виразів можна користуватися панеллю калькулятора з цифровими кнопками та кнопками швидкого введення назв стандартних функцій, що дозволяє вводити вирази за допомогою лише мишки, без використання клавіатури. Без використання панелі калькулятора всі необхідні символи можна ввести з клавіатури.


part15

15. Обчислення інтегралів вздовж контура

15.1. Послуга Обчислення\Інтеграл вздовж ламаної

Для наближеного обчислення криволінійного інтегралу від деякої функції виду z=f(x,y) вздовж контура у площині x0y або криволінійного інтеграла від функції виду t=f(x,y,z) вздовж контура в просторі можна скористатися послугою Обчислення\Інтеграл вздовж контура.

На вкладинці Інтеграл вздовж контура вікна Обчислення, що з'явиться, необхідно обрати тип підінтегральної функції за допомогою перемикача Тип залежності, після чого ввести вираз функції у поле біля напису Вираз.

Контур може бути заданий трьома способами:

  • у вигляді графіка явної залежності між змінними x і y: y=f(x);

  • у вигляді графіка параметрично заданої залежності між змінними x і y: x=f(t), y=g(t), де t - змінна-параметр;

  • у вигляді ламаної, що задається впорядкованим набором вершин.

Під написом Тип контура розміщено три кнопки з написами, що відповідають кожному з можливих способів задання контура

  • Якщо потрібно задати контур явною залежністю між змінними x і y, то слід "натиснути" кнопку Графік y=f(x) під написом Тип контура, після чого у відповідні поля ввести вираз залежності та межі

  • Якщо потрібно задати контур параметричною залежністю між змінними x і y, то слід "натиснути" кнопку Графік x=f(t), y=g(t) під написом Тип контура, після чого у відповідні поля ввести вирази залежності та межі t.

  • Якщо потрібно задати контур у вигляді ламаної, то слід "натиснути" кнопку Ламана під написом Тип контура. Далі можна або вибрати у полі Ламана назву відповідного (створеного заздалегідь) об'єкта типу Ламана (див.§4.3), або, "натиснувши" кнопку Графічно, за допомогою мишки вказати "з екрану" вершини ламаної у вікні Графічне задання ламаної, що з'явиться.

Після натиснення кнопки Виконати результат буде виведено у поле Результат обчислень.


part16

16. Налагодження роботи з програмою

ППЗ GRAN-3D оснащено засобами для зміни деяких параметрів роботи програми. Для цього призначено послуги пункту Налагодження головного меню програми.

При зверненні до пункту меню Налагодження\Параметри з'являється вікно Налагодження з вкладинками Зображення, Обчислення, Загальні та Кольори. У нижній частині вікна розміщено кнопки Запам'ятати, Скасувати, Застосувати. При натисненні кнопки Запам'ятати вказане вікно зникне, а всі зміни, внесені у налаштуваннях програми, будуть задіяні. При натисненні кнопки Застосувати всі зміни, внесені у налаштуваннях програми, будуть задіяні, але вікно не зникне, тобто можна продовжувати налаштовувати програму. Кнопка Скасувати використовується тоді, коли немає потреби зберігати внесені зміни у налаштуваннях програми.

На вкладинці Зображення у рамці Масштаб зображення можна встановити співвідношення коефіцієнтів масштабування зображення об'єктів вздовж кожної з координатних осей у полі зображення. За замовчуванням встановлено пропорційні коефіцієнти, але якщо вилучити відмітку біля напису Пропорційно, то у полях введення під вказаним написом можна ввести нові коефіцієнти. У рамці Центр повороту можна вказати координати центра повороту, навколо якого будуть повертатись зображення об'єктів і осей при використанні смуг повороту зображення. За замовчуванням центр повороту співпадає з початком координат, але якщо вилучити відмітку біля напису Початок координат, то у полях під вказаним написом можна ввести нові координати. У рамці Координати джерел світла (для півтонового режиму) можна вказати нові координати двох джерел розсіяного світла, що освітлюватимуть зображення об'єктів у режимі півтонового зображення.

На вкладинці Обчислення у полі біля напису Кількість точок поділу області інтегрування встановлюється значення, яке використовується при обчисленні за формулами чисельного інтегрування визначених інтегралів та подвійних інтегралів. Мінімальна кількість точок поділу - 2, максимальна - 1000. Чим більше значення встановлено, тим точнішим буде отриманий результат обчислення інтегралів, але і більші витрати часу на обчислення. Шляхом переміщення "повзунка" (за допомогою мишки), що знаходиться біля напису Якість зображення створюваних поверхонь, можна змінити якість зображення об'єктів типу Поверхня. Чим вища якість встановлена, тим більше часу необхідно на виведення зображення об'єктів, але відповідно зросте якість та точність зображення. У полі біля напису Кількість цифр у відповідях вказується кількість цифр, що виводитимуться на екран в результатах обчислень.

На вкладинці Загальні шляхом встановлення або вилучення відмітки ("галочки") біля відповідного напису можна вказати, чи потрібно:

  • зображати вершини (вузли) об'єктів;

  • зображати проекції поточної точки на координатні площини;

  • зображати номери вершин об'єктів;

  • виводити латинські літери замість номерів вершин (тільки якщо відмічено пункт зображати номери вершин об'єктів);

  • виводити номер об'єкта (під яким він знаходиться у переліку об'єктів) біля номера вершини (тільки якщо відмічено пункт Зображати номери вершин об'єктів);

  • зображати координатні осі;

  • вилучати зайві лінії граней опуклих многогранників (оскільки при створенні грані діляться на трикутники, що дещо ускладнює огляд зображення, в програмі передбачено можливість при виведенні зображення "об'єднувати" трикутники однієї грані в n-кутник);

  • автоматично завантажувати останній робочий файл (при завантаженні програми);

  • виводити шлях до робочого файлу у заголовку головного вікна.

На вкладинці Кольори можна змінити колір деяких елементів інтерфейсу програми. Всі елементи, колір яких можна змінити, наведено у переліку. Для зміни кольору певного елемента необхідно встановити вказівник переліку на потрібну назву (за допомогою мишки або клавіш управління курсором) та вказати на прямокутник з необхідним кольором, розміщений справа від переліку. При "натисненні" кнопки Відновити стандартні установки для всіх елементів переліку буде встановлено кольори, задані у програмі за замовчуванням.